Forum Thread: Apt-Get Not Working = Unable to Locate Package

Someone know what to do when you get this error? I get an error whenever i use Apt-get

This is the error when i try to "apt-get isntall": "E: Unable to Locate Package"

And when i try to "apt-get update":

W: GPG error: http://security.kali.org kali/updates Release: The following signatures were invalid: KEYEXPIRED 1425567400 KEYEXPIRED 1425567400 KEYEXPIRED 1425567400

Thanks in advance for helping me!

-I did all the above with "sudo" too without luck. same result.

16 Responses

your problem is expires keys.just copy this command in your terminal
apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6

sometimes package has different name so for example it's not veil but veil-framework .....
you can try type apt-cache search name_of_package and you'll see all available package

If the above doesn't work you can try this:
rm -rf /var/lib/apt/lists
apt-get update
apt-get install kali-archive-keyring

I actually already tried all the above you guys told me to do. I have searched the web as an insane for finding a solution without luck.

I hope you can figure out what is wrong with my "kali" when you see my error msg's. Thank you so much for helping me guys.

NOTE: remember to set the quality on the video up.
----------------------------------------

What i have learned so far by searching the web is I proberly had installed kali wrong. And now it's missing a important file. And i need to get that now, but i have no idea how. cuz when i try to, I get even more errors?!

lol you spelled "archive" in my code above as "archibe"

Did I ? Fail but i have tried that too, it didnt work. Any idea what i should do?

I had this problem when i reinstalled kali (about a week or two ago) and that code took care of it. If nothing is working, you may have a corrupt installation.

nice quote you got there xD

Are you telling me I should re-install kali?

No, I wouldn't would try and figure this out. It will build problem solving skills.

you missing wine...
apt-get install wine?

I had already installed wine, I did that some time before I posted this error on null byte.

Do you have any idea what i should do now? Im pretty damn lost :(

Alright seems like I just need to re install kali then :/

Thats gonna take some time, but thank you guys for helping me.
I really appreciate it :)

if you use virtual machine use 32bit system.... and you dont have problem with 32bit a 64bit libraries and compactibility

I've had this problem before. I fixed it with:

  • rm -rf /var/lib/apt/lists
  • apt-get update
  • apt-get install kali-archive-keyring

OR

  • apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 7D8D0BF6
  • apt-get update

# Sergeant

That didnt worked either.

Share Your Thoughts

  • Hot
  • Active