Forum Thread: Beef-Xss Is Showing Error

Beef-Xss Is Showing Error

i tried it on both my laptop and on my android phone (chroot (kali)). but in both places, i get an error...
when i execute beef from /usr/share/beef-xss/beef, even with the -x argument, it is showing me this:

./beef
22:20:52* Bind socket imapeudora1 listening on 0.0.0.0:2000.
22:20:52* Browser Exploitation Framework (BeEF) 0.4.6.1-alpha
22:20:52 | Twit: @beefproject
22:20:52 | Site: http://beefproject.com
22:20:52 | Blog: http://blog.beefproject.com
22:20:52 | Wiki: https://github.com/beefproject/beef/wiki
22:20:52* Project Creator: Wade Alcorn (@WadeAlcorn)
22:20:52* BeEF is loading. Wait a few seconds...
22:20:55* 13 extensions enabled.
22:20:55* 254 modules enabled.
22:20:55* 2 network interfaces were detected.
22:20:55+ running on network interface: 127.0.0.1
22:20:55 | Hook URL: http://127.0.0.1:3000/hook.js
22:20:55 |
UI URL: http://127.0.0.1:3000/ui/panel
22:20:55+ running on network interface: 192.168.0.107
22:20:55 | Hook URL: http://192.168.0.107:3000/hook.js
22:20:55 | UI URL: http://192.168.0.107:3000/ui/panel
22:20:55* RESTful API key: cfccc682721b38ffbf67dd6cb7801356729559cc
22:20:55* HTTP Proxy: http://127.0.0.1:6789
22:20:55* DNS Server: 127.0.0.1:5300 (udp)
22:20:55 | Upstream Server: 8.8.8.8:53 (udp)
22:20:55 |
Upstream Server: 8.8.8.8:53 (tcp)
22:20:55* BeEF server started (press control+c to stop)

/usr/lib/ruby/vendorruby/rubydns/server.rb:141:in `run': wrong number of arguments (given 1, expected 0) (ArgumentError)

from /usr/share/beef-xss/extensions/dns/dns.rb:128:in `block (3 levels) in run'
from /usr/lib/ruby/vendorruby/eventmachine.rb:968:in `block in rundeferredcallbacks'
from /usr/lib/ruby/vendorruby/eventmachine.rb:965:in `times'
from /usr/lib/ruby/vendor
ruby/eventmachine.rb:965:in `rundeferredcallbacks'
from /usr/lib/ruby/vendorruby/eventmachine.rb:187:in `runmachine'
from /usr/lib/ruby/vendorruby/eventmachine.rb:187:in `run'
from /usr/lib/ruby/vendor
ruby/thin/backends/base.rb:73:in `start'
from /usr/lib/ruby/vendorruby/thin/server.rb:162:in `start'
from /usr/share/beef-xss/core/main/server.rb:127:in `start'
from ./beef:154:in `<main>'
root@Gh0st:/usr/share/beef-xss#

and when I am running it from the menu, firefox is opened and says that it was unable to connect...after a while, the terminal says somekind of gtk error...

i tried disabling DNS extension....

what should I do?

6 Responses

Solution

I suggest searching NB or google for your error. This fix covers DNS as well as fixing authentication issues.

I have already done this... But couldn't get a solution... Their problem was a bit different than my one...

Post a screenshot of your command.

Edit in /usr/share/beef-xss/config.yaml
search for dns in the last line i guess make it false !

tried... but didn't work...

sorry, cant upload it... it wants a link from the internet
but can you please see the errors i have posted above?

Share Your Thoughts

  • Hot
  • Active