Forum Thread: How Can I Make My Kali Linux Apache2 Server Accessible to People Not Connected to My Network?

I use Kali Linux 2020 with Xfce4 and VirtualBox. I created a payload to send to my victim and was looking up delivery methods and thought that HTTP would probably be the best.

I used the service apache2 start command and the server worked fine on the OS itself. On my external Windows OS it didn't work. Then I changed the OS's settings from NAT Network to Bridged and this time it worked on the Windows machine and my local network. Then I routed my public IP (which also worked) to a free No-IP domain (

I want to make my server accessible to people beyond my network. Is this possible?

Thanks in advance,

2 Responses

I found the answer and for those who are stuck at the same problem, it's relatively simple and I'm dumb :E

1 - do ifconfig in the kali Linux terminal and remember your inet IP

1.5 - make sure that VirtualBox has a bridged connection to Kali Linux, not a NAT Network

2 - do route -n in the terminal and copy that gateway IP and paste that in your browser

3 - port forward the port 8080 (look up instructions on how to) from your inet IP

4 - now when you want to connect, turn on apache2 and connect with <yourpublicip>:8080

I was being dumb, and sorry for the crude answer, but I hope this solves your problem!


I did qll of this but when i try to connect from another device i get this eror:
This site can't be reached
Xx.xx.xx.xx refused to connect.

Checking the connection

Is it becuse of router firwall? I turn it off and even in the modem setting make it visibale to all ip range on wan. What is the problem? How does you don't get this eror?

Share Your Thoughts

  • Hot
  • Active