Forum Thread: Can't Get a Station with WEP

Can't Get a Station with WEP

These are the following commands I have done.

ifconfig wlan1 down
iwconfig wlan1 mode monitor
ifconfig wlan1 up

airodump-ng wlan1 <- This does show all APs in range
airodump-ng --bssid <macaddresshere> -c 4 -w filename wlan1 <- This is where my issue is
aireplay-ng -3 -a <BSSID> -h <station> wlan1 <- haven't run this command yet because previous one doesn't work

My issue on the noted command is that it doesn't show any stations when I have a phone connected to it with data being transferred. As always thank you in advance!

19 Responses

What output/error are you receiving when running that command?

I don't get any. When I do the noted command it shows the data and such from the AP but it doesn't show the station's that are also connected like it normally does.

What version of Kali are you running ?
Any particular reason you don't start monitor with airmon-ng start wlan1 ?
Can you post a screenshot or paste of the full error line ?

Sorry. I''m a bit off these days, I'm sure someone will promptly spot the problem, but just in case, answering those will help.

I agree with TripHat.
airmon-ng would be more suitable for placing the device into monitor mode.
Try that and please report back :)

I have done it both ways. They both get the same result but they both switch to monitor mode.

I am running Kali 2

Image via imgur.com

Are you running on live / installed environment or vmware / virtualbox ?
Shouln't you have a wlan1mon to feed the airodump-ng as you are in Kali2 (I still use old one sooo..) ?

It is installed on an old laptop. Also ifconfig and iwconfig only shows wlan1 and wlan0 (which I don't use cause it is built in and doesn't work for this)

Try from a fresh reboot and airmon-ng start wlan1 ... if wlanXmon doesn't show ( where X is 0 or 1, not sure how are assigned on K2 ) there might be a problem with putting the interface in monitor mode.

You said you already used that adapter to crack WEP (what's the adapted name btw ?). but with what version of Kali ? Were the commands the same you typed above ?

NH huh, so it might be just like Jason said in his post below... they don't show or are delayed... can't test because I have the 036H, but still, airodump-ng 's interface argument should be the one in monitor mode, so mon0 or wlan0mon, not the wlan1 (given that you can succesfully create it with airmon-ng)

This is why doing airmon-ng doesn't work at least I think it is related

root@DedicatedKali:~# airodump-ng wlan1mon
ioctl(SIOCSIWMODE) failed: Device or resource busy

ARP linktype is set to 1 (Ethernet) - expected ARPHRDIEEE80211,
ARPHRD
IEEE80211FULL or ARPHRDIEEE80211PRISM instead. Make
sure RFMON is enabled: run 'airmon-ng start wlan1mon <#>'
Sysfs injection support was not found either.

Also as a side note I have seen stations show up quickly on this card, not instant but the delay is under 5 seconds

I found online a list of processes that could make this happen and I found and killed them and it worked. Hmmm weird. I will try with this now and if it doesn't work I will be back.

oh, too late then... googlling that error I got, among others, this,

That works well. Thank you for your help :D

If it's not showing stations - this can actually be an adapter problem.
I've run into this myself, are you using the Alfa036NH? by any chance.

Because, on my NH, stations don't show, or they're delayed.

On the other hand, my AWUS036H, shows stations all the time.

Also, your channel is on 4.
This can cause issues, I recommend setting the channel of your test Access Point to 1 , 6, or 11.

I just choose 4 because it was different from channel 11 of my main wifi. Also I have done WEP cracking with this adapter before.

Share Your Thoughts

  • Hot
  • Active