Forum Thread: Can't Use New Module after installing it

Can't Use New Module after installing it

As the pic shows,i have moved that file to /root/.msf/modules/exploits/windows/flash and also restarted metasploit, but i can't find the exploit in metasploit.How to solve it?

9 Responses

I just recently had the same problem. It was extremely frusterating but I ultimately realized I wasn't using the most up to date version of metasploit. To see what version you're running type: msfconsole -v. The most up-to-date version is 4.11.5. After you update, you'll notice rather than having a '.msf4' folder, you'll have a '.msf5' folder. Add your module the same way you normally except use the .msf5 folder (obviously). Once I updated my version, I had no problem with my modules being added. Let me know if this works.

Sorry,it still doesn't work. My metasploit version is the newest,and after i replaced .msf5 to .msf4,the result didn't change...

I'm sorry I should have clarified, you shouldn't have to change the folder back to .msf4. I don't think that's going to fix your problem, I'm just saying...

First, this question should have been posted in the comments section of the tutorial on new modules.

Second, have you tried "use" and the name of the module. The search function in Metasploit is buggy.

msf > use windows/flash/adobehackingteamexploit

  • Failed to load module: windows/flash/adobehackingteamexploit

The exploit i installed is bulit for metasploit...i know.

The path to the exploit should begin with "exploits"

Then, you must have placed the module in the wrong location. Make certain that the new module is in the same location as the other windows/flash modules.

And just looking at the pics, is your metasploit still saying 'cache not build using slow search'? If it is you need to db_rebuild_cache. Also, I see your saved your module as 'adobe_hackingteam_exploit.rb'. So when you use msf> use exploit/windows/flash/adobehackingteamexploit', it's not going to find it. Have you tried msf> use exploit/windows/flash/adobe_hackingteam_exploit? Let me know if it works. If so, gimme kudos :)

Share Your Thoughts

  • Hot
  • Active