Forum Thread: Changing TXPower? Impossible... :(

Changing TXPower? Impossible... :(

Hello my friends,
yesterday was experimenting some Evil Twin techniques and was in need to raise my txpower.
At first tried to switch my reg to BO without any success.
Then i found some tutorial here and around the web and changed my regulatory.
Now if i type "iw reg get" i get the right values (30) for everything (i changed it for 00, BO and my country).
The problem is that doesn't matter what region i set (BO or my country) my txpower still be at 20dBm
That's what i do:
*ifconfig wlan0 down
ifconfig wlan1 down
reg set BO
ifconfig wlan0 up
ifconfig wlan1 up
iwconfig wlan1 txpower 30*

I don't get any error but my iwconfig show my txpower at 20.
I tried even in this way:
*ifconfig wlan0 down
ifconfig wlan1 down
reg set BO
iwconfig wlan1 txpower 30
ifconfig wlan0 up
ifconfig wlan1 up*
But doesn't matter, still get always my txpower at 20

Tried with many different adapters but nothing change, i'm running kali 2017.1 totally updated

Someone can put me on the right track?

Thanks ;)

3 Responses

Hello and thanks for answer, my external adapter is a TL-WN822N v3.0 with a RTL8192CU chipset... It should work, the funny thing is that i can not even lower my txpower :D Always TX 20, doesn't matter what i do.

Lol, I too had a TL-WN822N v3, and NETGEAR WNA1100, I could lower TX in WNA1100 but not in TL-WN822N v3, and couldn't raise it in any of the two, well in WNA1100 it's understood (does not support), but in TL-WN822N v3 .. I got no clue.. (except that chip-set is the problem bcz, it was possible to mess with tx in v2)

Also, (for me) WNA110 worked far better than TL-WN822N v3, even though it was neither high gain nor supported high power.

Tip: Buy an alpha like I did. (I had TL-WN822N v3 replaced by Alpha, (amazon))

Share Your Thoughts

  • Hot
  • Active