Forum Thread: How Do I Set Up Repositories and Wifi in Kali Linux

How Do I Set Up Repositories and Wifi in Kali Linux

I just installed Kali on my MacBook Pro (13-inch, mid 2010), but when I did I didn't have an internet connection. Now, I don't really have repositories, and my wifi is all screwed up. I think I need the drivers for my card and I definitely need repositories set up. Can someone please tell me how to do this? I've looked on google and various forums, but I can't really find anything. I also really don't want to mess up my Kali and have to start over. PLEASE help me.

9 Responses

I looked through them and did find anything that helped too much. plus Kali is Debian based and most of your tutorials on Backtrack which is Ubuntu. I don't know if this matters, but I really don't want to mess up my OS.

My wifi card is "02:00.0 Network controller 0280: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller 14e4:432b (rev 01)" according to the "lspci -vnn |grep Network" command.

I also clicked the network icon on the top bar, but that only works for a second and then wants the password again for the wifi then rejects it and repeats.

I figured out the repository thing though. I just need my wifi card to work so that I can get online without an ethernet connection and so that I can use aircrack. Because every time I've tried using aircrack in the past on any OS it tells me that mon0 is in monitoring mode and gives me an error when I try to start wlan0 (using the steps in your tutorial). I assume that all of this is a driver problem. I'd really appreciate your help in fixing it. The rest of the web hasn't been to much help.

Never mind. I think I fixed it. I'm not totally sure though.

I don't know specificly, and since you didn't mention what you tried and didn't try i will take guesses.

Top of the screen has a Wifi bar, click on it and choose your network... pretty obvious

If that doesn't work go to System settings, then networking options and try connecting from there. I'm not logged into kali right now so it may not have "system settings" or "networking options" but it will be similar

It's highly likely that they need to install drivers for the wireless adapter.

ghost_

I agree with ghost_. Although I didn't have to install them on my macbook pro in order to get Kali Linux to work, I had to on other distros.

Consider though, that the user has installed on a 2010 machine. Driver packages are likely not included in the latest Kali distributions.

ghost_

Oh, sure. I'm using a 2010 MacBook Pro machine too, however I understand where you are coming from. Ubuntu does not have drivers for my pc.

Hm, then it could be something else entirely. I would suggest the user to check on Ciuffy's post here.

ghost_

Share Your Thoughts

  • Hot
  • Active