E: Unable to Locate Packages in Installing Any Tool to Kali on Android

E: Unable to Locate Packages in Installing Any Tool to Kali on Android

Hello guys ...hope this topic finds you well

so yeah as the title say this is the issue can't install any tool on kali using android with apt-get install <e.g Ettercap>

the only tool i could install is Metasploit and works well
any help would be appriciated , thanks.

45 Responses

Are you getting an error message?

ghost_

Mmm ... yes " E: Unable to locate package (the tool)
thanks for reply

I'm having another error when i do some commands , I think there is a connection between the two problems
" perl: warning : Setting locale failed
perl : warning: please check that your locale settings:
LANGUAGE = "enUS.UTF-8",LCALL= SAME , LANG =SAME
are supported and installed on your system
warning falling back to the standard local ("C")
at the End
E:Sub-process /usr/bin/dpkg returned an error code (1)

It looks like locale settings are wrong, try this.

sudo apt-get purge locales

sudo aptitude install locales

sudo dpkg-reconfigure locales

That should get rid of the current system locales, then reinstalls locales, and configures the locales again.

Let us know if this solves the problem or not. If not; then please post screenshots.

ghost_

I did the commands the last one result says :
At the end : Error: invalid locale settings: LANG=en-US.UTF-8

There's no locales package installed.

EDIT: The purge command didn't work because no locales packages have been installed.

ghost_

What do you recommend me to do
I tried apt-get install locales same error with a fail : Postgresql must be started before metasploit
invoke-rc.d: initscript metasploit , action start" failed
perl: warning : settin locale failed
At the end :
E:Sub-process /usr/bin/dpkg returned an error code (1)

now I don't have metasploit tried to install it the previous error pops up
E: Sub-process .....
so Can't install metasploit anymore

P.S installed metasploit before but uninstalled it with a command that i didn't know it would uninstall it ,was following a guide to fix the issue

Yes I'm frustrated and need help :S

I think I tried those commands and it didn't work I'll try again and inform you of the results
thanks ...
can you list down commands for installing and reconfiguring locales
Are they : install = apt-get install locales ?
for the configure = don't know

*Puts down the popcorn
Greetings, this is another one I have never seen or fixed but have you tried:

sudo locale-gen en_US.UTF-8

sudo /usr/sbin/update-locale LANG=en_US.UTF-8

this yet? Maybe it helps maybe it don't. Back to the show.

Hang on I'll try means no
Thanks ...

first command : generating locales ,generating complete
second Perl: warning : Setting locale failed
perl: warning: please check that your locale settings are supported and installed on your system
perl: warning: Falling back to the standard locale ("C")
* update-locale: Error: invalid locale settings: LANG=enUS.UTF-8
:S

Now lets try:
sudo dpkg-reconfigure locales

the blue and gray screen appears ...
what should i choose all locales or else ?
Thanks ...

Whatever you need. Like I was saying I have no clue what you are doing over there. :-P

exit 1

I would choose all if unsure cant hurt too much.

i entered the command and the package configuration pops up i can choose one of locales to be generated :
All locales
and the rest of the locales

now it's asking me for the Default locale for the system environment...

for this I'll choose ...
enUS.UTF-8
is it alright ?

enUS or the previous that i mentioned
appriciate the help!!

I will defer my advice to PM because this is way too much single word posting from this thread soft addict.. ;-)

Also the locales issue should be fixed now.

I wonder why this happened... maybe it's because of latest Linux Deploy updates...

Ya me too ...

anyway I deleted the old image deleted linux deploy and the rest of the apps and reinstalling the system I'll see what change and i changed the Architecture to Armelhf

installation about to finish
so what are the main things that i have to do after installing the naked image ?
apt-get update? or something else

Yeah not sure either. This did fix his locales issue but he still has issues running other packages.
I had him run:
apt-get clean && apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y
Not sure if that helped his other issues.

Nah didn't work out apt-get clean && .....

I think my issue with E: unable to locate package remains with the repositories but weird im using the official ones !!! :S

same error when installing tools

E: Unable to locate package <tool>

i managed to install bluesnarfer
but Setoolkit and other tools doesn't seem to work on android somehow ...
anyway that proves that apt-get install is working
Thanks Guys I'm glad you helped me and hope i return the favor in the soon future :P

P.S apt-get upgrade not install

locales issue is solved completely no problems regarding it
But .. still getting unable to locate package in installing tools which is very annoying
command used : apt-get install .. tool , apt-get upgrade tool
:(

Thanks bro Romeo i already installed SET ;)

Thanks friends!!! Very Helpful discussion :-)

My android Kali Linux browser is also not working

That was allot of reading considering it didnt resolve the issue,

Share Your Thoughts

  • Hot
  • Active