Forum Thread: Firesheep

Firesheep

I tried downloading from a few different sights. All say that Firesheep is not compatible with Firefox. I have the latest version. Has Firesheep just not not cought up to it yet?

Be the First to Respond

Share Your Thoughts

  • Hot
  • Active