Forum Thread: Fix Meterpreter Problem

Hi, lots of people including me had a problem in the meterpreter. Just Like this :

Here, I will show you how I solved this problem.

Step 1: Updating & Upgrading

I tried updating the metasploit framework, and it was the first key to solving.
I did :


then it said it does not support after it was preinstalled, blablabla...
then I did:

apt install metasploit-framework && apt upgrade metasploit-framework

then it upgraded a bunch of things.

Step 2: Adding Port

I use VMware 12 Pro, I usually mess up with it, then I somehow figured out.

First, go in the terminal and type :


then get your ip address.(copy or write it down on a piece of paper)
Now, get the machine off.
Then, make sure your network adapter is NAT.
If it is not NAT, then change it.

Now, you checked it is NAT, so go to the top and click edit > virtual network editor.

Click on Change Settings, then click Yes.
now you can edit it.
Click on the VMnet that has NAT on it, in my case it was VMnet8.
Click on NAT Settings.
Click "Add..."

Put your host port, it can be any number, then put your IP where you copied(Or written) on the next, then in the third space, put the same port number which you wrote in the first. Then click Ok, and Apply, then you are done.

Did This Work?

So, this method worked for me, but I do not know about yours, try it, if it worked, then you can keep hacking, and if it didn't, comment down below and I will try my best to help you.

2 Responses

im having this same problem and nothing is working. It connects to the target device just fine (in this case its a galaxy s8). The apk file is installed and running and the session opens but get stuck on the "handler" and wont switch to meterpreter so i can start using commands :(. Iv tried updating metasploit and the internet process in your tutorial but neither worked.

hey sir can i ask question?
do you use wireless adaptor ?

Share Your Thoughts

  • Hot
  • Active