Gnome: Help

Gnome: Help

Hi,

so i ran apt-get upgrade (running kali 1.1) and it started downloading all the packages and then started setting them up and part of the packages is the new GNOME: gmd3, during setting up gmd3 it showed a grey screen in the terminal with lots of text about configuration --which i didn't read-- and an< ok > at the end which i couldn't click and kept pressing enter but nothing happened and it wouldn't go away, so i closed the terminal, opened new one and ran apt-get upgrade but gave lock error (still being used) so i rebooted and that's when i got the screen <Oh no! something went wrong, logout and try again> which i did but kept giving the same outcome.

Image via dedoimedo.com

I tried many things:

  • Ctrl+Alt+F1: logged in as root (tty1)and: "systemd-logind2519: Failed to start user service: Unknown unit: user@0.service"
  • ran apt-get insatll --reinstall gmd3 which ran successfully but nothing changed with the login screen
  • dpkg-reconfigure gdm3: ok scheduling gnome configuration. and that's it
  • gdm3: shows gdm3 2606 error connecting to system bus
  • apt-get install gdm3: gdm3 is already the latest version. gmd3 is set to manually installed
  • Xorg: fatal error
  • cat /etc/gdm3/daemon.conf: (as i remember showed this)

AutomaticLoginEnable=true
AutomaticLogin=root

*btw I have a root and non-root user
Does anyone know what the problem is, or how it can be fixed ?

6 Responses

what happened when you logout and try again? do you get a terminal prompt ?

Hacked by Mr__Nakup3nda

presented with the same screen again. (this what i see right after booting and keeps going in a loop)
I do get a terminal with network connection (tty) by pressing Ctrl+Alt+F1 or F2

Is there anything of value that would be lost if you did a clean install? If so, you could back up the important data to some network storage, then clean install.

-Defalt

first method

apt-get update

apt-get upgrade -y

apt-get install -f gdm3

second method
fsck /dev/sda1

hacked by Mr_Nakup3nda

Running on a VM?
Had the same problem with the newest version of VmPlayer and Kali 2.0.
Changing the environment to virtual box helped me a lot ;)

Share Your Thoughts

  • Hot
  • Active