Forum Thread: Help Alfa AWUS051NH v2 Stopped Working on 5ghz on Win 10

im using Alfa AWUS051NH v2 wireless card and up till yesterday it worked fine on both 2.4 and 5ghz networks.On my win10pro desktop machine

But after turning on pc yesterday i couldn't connect to 5ghz band anymore. basically it tries to connect and drops signal completely and goes back to 2.4ghz band or gives message cant connect to to this network.

now i know this card is rare so only long shot i have on this forum.

i know it doesn't support full 802.11ac, but my router has a/n/ac mixed, and n/ac mixed options , but alfa utility sees it as ac - tried every possible driver i could find and latest ones think were going back to 2018 but seems more like any work discontinued on them since 2015 for windows.

i did plug it into my kali linux machine and had no issues to connect to my 5ghz wireless.

ive no clue how it worked fine before, but guessing after several hard reboots windows pushed another update, also had java update pop up on the same day, basically went uninstalling all drivers, testing different bands etc - different drivers to even windows ones and keep getting 802.11n which would be fine but alfa utility only sees ac, thou it had no issues with that before.

other steps taken removing all drivers- clean install no help
disabling firewalls password for wifi, leaving only 5ghz band no luck
using drivers from disk doing win 7- 8 install same no luck
any info online is almost as if no one owns this card :(
safe mode - no luck
changing freqencies bands ssid, encryption on router no luck
yet in kali didnt even need to load any drivers,connected no issues.
im out of options to figure this out at this point.

Using crappy isp router virgin media hub 3.0- which has only 3 options for 5ghz band a/n/ac mixed, n/ac mixed, ac

as i do use linux but on windows10 i need 5ghz as everyone else uses 2.4 so this leaves me with stable connection for myself. to work on different things and stuff.

totally bummed out finding basically no support for this card on windows 10, as it works fine on 2.4ghz band but something is choking it from connecting back to 5ghz.

Sorry for long post but trying everything from clearing all connections to using advanced settings and testing each function in device manager im at a loss as not sure how it worked fine before, since giveaway was light turned orange when on 5ghz band its greenish.

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

2 Responses

sorry dont want to spam but found extra step ive missed when checking for drivers when i un click compatible hardware, i can browse by manufacturer- theres two options for ralink but only one section has exact chipset Ralink RT3572

so far ive tried a/b/g/n, generic 150mb, an, but to no awail i get message to enter password for network but seconds later it just drops connection either way and reverts back to 2.4.

just an update seeing no response here went to contact alfa support and they were actually quite helpful in trying to help with drivers and trouble shoot but still no luck, as card fails to see beyond ac in alfa utility and doesn't pickup neither a or n network that router transmits as it works fine with kali out of the box on 5ghz band, but not on win 10 .

Now wont blame alfa as they did try to help as soon as they could, so im stuck now on 2.4ghz network when using windows.

seeing article for what cards to pick that was released think last year, only thing i would say that whoever writes em should put up more information as whether cards offered are in full support or old generation ones that have been superseded, and info on development regarding capabilities as many offer future developments which usually lies within independent developers to choose either to support chipset or have it limited.

Share Your Thoughts

  • Hot
  • Active