Forum Thread: Hi, I Need Some Help with Reaver

Hi, I Need Some Help with Reaver

First English is not my first language so I may have many mistakes writing ^^.

I read a lot in NullByte and also search Google but still no help with my problem so I think it's time to ask.

I have a router (I know its password of course) and my laptop is like 2 meters from it. I also have my friend's router next room, 5 meters from my laptop, both have WPS enabled. Signal is perfect.

Problem is when I run below command (which was success before for both routers)

reaver -i wlan0mon -b myroutermacaddress -c 2 -K -1 -vv

it shows:
! WARNING: Failed to associate with XX:XX:XX:XX:XX:XX (ESSID: (null))
! WARNING: Failed to associate with XX:XX:XX:XX:XX:XX (ESSID: (null))
... a lot of it
Sometime it does get associated, but rarely, only 1 or 2 times and then
! WARNING: Failed to associate with XX:XX:XX:XX:XX:XX (ESSID: (null))
! WARNING: Failed to associate with XX:XX:XX:XX:XX:XX (ESSID: (null))
...a lot of if again. It's stuck.

Both routers are not updated. But I did update my lap with
Apt-get update/upgrade/dist-upgrade (several times)

In short:

  • I was success hacking both routers with the same command in the past, now I can't. The only thing get updated is my laptop.
  • Signal is good
  • WPS enabled and not locked
  • I check my mac address, still the same, no changes
  • My wireless card is good.
  • I did have some line say that it's associated but then failed again.
  • I tried with wifite, same problem.

Please suggest. Thank you very much!

11 Responses

You need to add the -e <essid> option to the command.

To find your ESSID, do the following:
iwconfig | grep ESSID:
You should see some thing like this in the output:
wlan0 ESSID: <this is your essid>

Thank you very much for your fast reply, I never use -e option before but I just try it as you suggest, still the same output.

It seems like reaver isn't connecting with the router right... try adding this to the command...
-A aireplay-ng -1 0 -b target bssid -h your mac monitor interface

Yeah, I try with this (-b doesn't work so I use -a)
aireplay-ng -1 0 -a targetbssid -h mymacaddress wlan0mon
This command success, I get Association successful.

Then I use reaver -i wlan0mon -b myroutermacaddress -c 2 -K -1 -vv -A
It says:
Warning: Receive timeout occurred
Sending EAPOL START request
So on.......nothing happens after that.

add "-T 0.5 -x 360" to your reaver command and try again.

It doesn't pause after 10th error Warning: Receive timeout occurred.
Wait for 20 of them and still the same
Warning: Receive timeout occurred
Sending EAPOL START request
Warning: Receive timeout occurred
Sending EAPOL START request

often times, AP's will change their channels as a defense. Don't use the -c option and reaver will automatically hop from channel to channel

I use wash -i wlan0mon and see that AP doesn't change the channel, but I tried remove -c option, still no luck.

It sometimes received M1 message.

WARNING: Failed to associate with XX:XX:XX:XX:XX:XX plz help me

I have exactly the same problem.. I've been searching for a solution for almost a week with no luck.. some suggested you downgrade your libpcap to 14.02 but for me something was still not working.. please inform us if you find a solution

Share Your Thoughts

  • Hot
  • Active