Forum Thread: Installing Kali on Android Phone Storage

Installing Kali on Android Phone Storage

My phone storage(8gb) has larger capacity than my sd card(4gb). But all the tutorials I found is about installing kali on an sd card. I don't know how to direct the installation path to my phone storage. I tried /storage/sdcard1/linux.img but when I start installing it, I always get the error "Making file disk image.. /fail"

I am using the Linux Deploy app to install kali. Does anyone knows how to fix this?

21 Responses

Fortunately, I had this problem too and solved it.
To install it on your storage, leave the default path, which is:
/storage/emulated/0/linux.img

Make sure you have enough space.

if the error making disk image fail pops up, try to change the image size (under path) to 4000 fixed MB.

To delete you distro, in case it occupies too much space, you can simply go to settings->remove enviroment,or navigate to the .img file with a root browser and delete it.

I don't get the downvotes.

still doesn't work. Do I need to uninstall the BusyBox app? The tutorial I found required me to download and install BusyBox app before installing kali from Linux Deploy

Hi, i think better it should be installed on partition. Download AParted on your SD card, delete all partitions in tools tab, then create first partition fat32 , and second ext2.

In linux, deploy press status, and find partition with that size. In properties:
Installation type: partition
Installation path: string from "status"

See here about kali installation.

Sorry for my broken english.

Can I use my phone storage to make partitions using that app??

Absolutely don't try that. You might encounter serious poss of data.

It is true that you need the correct format to be able to install it, but it worked for me on storage. You don't need to uninstall busybox. If that really helps, you can either:

-use busybox and not use Linux Deploy's built in shell.
-use Linux Deploy's built it shell.

And, you can activate error logging in the settings. Maybe that can help you. Are you root? Did you give the enough permissions? Just some troubleshoot until I get home and try it myself.

I found a new problem. I enabled the error logging and it says "dd: opening '/storage/emulated/0/linux.img': No such file or directory"

So, we got a little bit further.

Do you have a Root Browser? Have you first downloaded and installed Kali with the "install" button in the distro settings?

Because it seems like the .img file has not been created.

Yes I do have Root Browser. I think the .img wasn't created since whenever I click Install from linux deploy, the installation process ends with "Making new disk image (4000 MB) ... fail"

I was following your tutorial about installing kali on android. But I still get the error "Making new disk image (4000 MB) ... fail"

It might obviously be because of not enough free space. It doesn't really rquire that much. Try with less, are you sure you have at least 4 gbs free? The Bootstrap minimal installation shouldn't require that much.

Checked it myself: with metasploit and minor tools installed it takes 66% of the 4000 mbs I allocated. You can try with less, however make sure that once the installation starts, it will tell you that there's no more space once it is filled up. So the installation could start, but the space might not be enough. I'd suggest you to try with 3000 mbs, to make sure you have free space for additional tools you'll install. 2400/500 should be the minimum.

can i change the resolution of my desktop in kali. im using kali in android ..

Linux Deploy?
Settings distro -> GUI Settings

but it doesnt effect the resolution in vnc session.. i need bigger icons without zooming.

Guys to all you geeks out there! I am totally new to linux, Have a query!
Firstly, do I have to install Kali on to my laptop to excess the Kali gui on my Android phone!??

I have installed Kali.img and have successfully booted Kali on to my Android phone works fine! My problems is that I can't get vnc to work or the gui to start! Like shown in this video! The only diffrence to this video is that I am not using the Linux deploy from google play but the Complete Linux installer which is also from Google play! Confused out here! Cheers! Guys and girls!! Shalom!!!!!!

What do you do to access it? Address, password?
Of course you don't have to install Kali on your PC too.

Complete Linux Installed gave me some problems, I usually go with Deploy, so I am not an expert, should review it soon...

i also go same error of selected extractor cannot found ar

Has anyone managed to fix the issue with the extractor not being found ? I seem to be having the same problem. After mounting the partition and installing the Debian base distribution it says "E: The selected extractor cannot be found: ar". Iv followed a few tutorials but the error keeps coming up. I'm using a rooted Samsung S4 running 5.0.1. I have busybox installed successfully. I have 8GB of space available on internal storage and an empty 4GB SD card. The only thing I can see that is different when I go to the distribution suite the only option I have are sana and Kali rolling. Not sure if that would have an impact. Any ideas ?

When I try nd extract the large image that I downloaded from sourceforge, it extracts around 90% nd then says input output error or something like that. What do I do?

Share Your Thoughts

  • Hot
  • Active