Forum Thread: installing Kali from USB ?!!

I want to install Kali on my hard drive so i wont waste time plugging and unplugging the USB.

when i go on and click on graphical install or just install, i notice something at the beginning it doesn't last long before disappearing ,, it goes something like failed to mount media , mount unmount dev/sda no arguments stuff like that,,

and if i continue with the installation, At some point it is detecting and mounting CD-ROM drives. As I have no CD-drive or any ROM-drive on my laptop, i don't know what to do?

6 Responses

/dev/sda in this situation should be the USB media. Maybe try writing the image back to the USB and see if you get the same errors. You can also check the md5/sha1sum of the image to see if it matches the checksum of the same version on kali's website.

My kali version, is updated , i just download it yesterday, and as for the usb i don't think that i can do anything with it since it was used once i mean like burned.

I wasn't talking about the version of kali itself, you should check the checksum to see if kali was written to the USB correctly.

Also, USB's are different from writable discs. You can write as much times as you want to them. The reason writable ONLY discs are writable once is you "burn" the data into them and there is not altering the data after that. However, it is different for re-writable discs.

You can do what the below guy said but instead of mounting to the CD-rom you should mount it to were kali usually mounts and go from there. You can find that out watching videos on kali (I don't know personally). But check to see if you have the correct checksum first, that's easier.

ok i will thank you

Yo - first post here, love this site.

I had the same issue - what to do is go through the install process until you reach the point you can go no further, it'll bring the menu back up and you will have the option to execute a shell.

From the shell you need to mount your USB to the /cdrom directory:

mount -t vfat /dev/sda /cdrom

If the /cdrom directory doesn't you'll have to make that directory first then mount the USB there:

mkdir /cdrom
mount -t vfat /dev/sda /cdrom

Then you can exit from the shell and it should detect the install media in /cdrom

Only issue I have now is that I can't get grub or lilo bootloaders to install.

Hope this helps.

try unplug and plug the USB when you get the message. It worked for me

Share Your Thoughts

  • Hot
  • Active