Forum Thread: IPv4 vs. IPv6

IPv4 vs. IPv6

Hello!

I'm quite new to all this and need some help, especially since i couldn't find too much Information about it on the Forum.

I know IPv6 is the new hexadecimal version of the IP, but what exactly does that mean? I'm sure there are some big changes to it..

When using online services to get my IP, I'm able to get the IPv4 AND the IPv6.. but when i type ifconfig in the shell it just shows me the IPv6.. can someone explain that, please?

Does my Computer forward both IPs? Or are they even the same just in another format? Which doesn't make much sense to me..

Now if was about to use a tool, that requires my IP, which one would I use? (If not shown explicitly)

I'm a little confused about this, i hope someone can enlighten me. :)

4 Responses

This is really technical but if you skim through it you can find most of the answers to your question. I don't know a lot about IPv6 and I should know it better.

A couple of the main differences is that IPv4 address are 32 bits long, whereas IPv6 address are 128 bits long. This means that there is a finite number of IPv4 address, but a seemingly infinite number of IPv6 addresses. IPv6 does have some advantages over IPv4, but majority of networks currently use IPv4. As for why your IPv4 address doesn't appear, do you have DHCP enabled? Also, for running tools, you would use your IPv4 address.

-Defalt

Fantastic explanation. To add to this, I would attribute the differences to be similar to 32 and 64 bit operating systems.

Also, IPv4 is binary whereas IPv6 is hexadecimal.

IPv6 encrypts traffic and checks packet integrity, meaning better security.

IPv4 allows for 4 billion internet addresses, IPv6 allows for approximately 340 trillion, trillion, trillion internet addresses. To put that into perspective, imagine IPv4 address space is the size of a postage stamp, IPv6 address space in comparison is the size of the solar system.

Any other information, I would recommend looking up the respective protocols and reading up on them. It's always good to know about technology.

ghost_

Thanks, i guess I'll have to learn more about the protocols.

After trying some things out i have new questions.

I tried to find out if DHCP is enabled or not for some time now.. It seems that it is.. still the IP remains the same after system reboot etc.. is that normal?

So i tried dhclient -r -v wlan0" and then dhclient -v wlan0 to change my IP-adress.
It worked..kind of.. only that afterwards the IP still is the same as before..

When I do dhclient i just get:
$ Job for smbd.service failed. See 'systemctl status smbd.service' and 'journalctl -xn' for details.
$ invoke-rc.d: initscript smbd, action "reload" failed.
$ RTNETLINK answers: File exists

I read a lot and am even more confused now, hopefully you can help me again.

How can i be sure, whether I'm using DHCP or not?
And what does the error prompt after dhclient mean?..
Why can't i get a new IP?

Lots of questoin, but i wasted lots of time on that already. I'm sure you can clear things up a bit. :)

Share Your Thoughts

  • Hot
  • Active