Forum Thread: Kali Isn't Detecting My Alfa AWUS 1900

Hey I recently bought the Alfa AWUS 1900, because of the great signal strength ( 4 omnidirectional dual-band antennas), but my laptop isn't detecting my dongle. I thought that with this chipset it's „plug'n play" on linux distros.

I'm using Kali Linux, my kernel version is 4.18.

I'm not sure whether the dongle is broken or not because it's pretty new, but I tried :

apt-get update && apt-get upgrade && apt-get dist-upgrade
apt-get install realtek-rtl88xxau-dkms

It's possible that this dongle hasn't a chipset which is capable of packet injection and monitor mode ,but even though it should at least beeing detected or am I wrong ?

Thanks for your help :)

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

3 Responses

Hello,
I have it.It support monitor mode and injection but he dont work on fluxion 5.6.
Did you reboot kali linux when you installed the pilot?

Hey thanks for your answer.

Yes I did ,but the dongle is still not beeing detected. Someone on amazon posted a link for the working linux drivers. I gotta check them out hopefully they

will work.

Are there different chipsets for the ALFA AWUS1900, which arent capable of packet injection and monitor mode ?

Share Your Thoughts

  • Hot
  • Active