Forum Thread: Kali Linux 2017.3 Update Error and Wifi-Pumpkin

When i try to update my linux and try to upgrade it
i get a error message like thisoot@kali:~# apt-get update
Get:1 http://deb.i2p2.no unstable InRelease 12.3 kB
Err:1 http://deb.i2p2.no unstable InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 67ECE5605BCF1346
Reading package lists... Done

W: GPG error: http://deb.i2p2.no unstable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 67ECE5605BCF1346

E: The repository 'http://deb.i2p2.no unstable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

please help me put with this issue

and please look here if you got some extra time dear

when i was installing wifi-pumpkin
i get this error or something

after i ran the installation command

| wifi-pumpkin Installer|
=============================
Version: 0.8.5
usage: ./installer.sh --install | --uninstall
Get:1 http://deb.i2p2.no unstable InRelease 12.3 kB
Err:1 http://deb.i2p2.no unstable InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 67ECE5605BCF1346
Reading package lists... Done

W: GPG error: http://deb.i2p2.no unstable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 67ECE5605BCF1346

E: The repository 'http://deb.i2p2.no unstable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libssl-dev
E: Unable to locate package libxml2-dev
E: Unable to locate package libxslt1-dev
E: Unable to locate package zlib1g-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libarchive-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libnetfilter-queue-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
hostapd is already the newest version (2:2.4-1.1).
python-scapy is already the newest version (2.3.3-3).
rfkill is already the newest version (0.5-1+b1).
python-qt4 is already the newest version (4.12.1+dfsg-2).
The following packages were automatically installed and are no longer required:
android-framework-res android-libaapt android-libandroidfw
android-libbacktrace android-libbase android-libcutils android-liblog
android-libunwind android-libutils android-libziparchive junit libantlr-java
libantlr3-runtime-java libapache-pom-java libatinject-jsr330-api-java
libcommons-cli-java libcommons-io-java libcommons-lang3-java
libcommons-parent-java libguava-java libjaxp1.3-java libjsr305-java
libprotobuf-lite10 libsmali-java libstringtemplate-java libxmlunit-java
libxpp3-java libyaml-snake-java
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-dev is already the newest version (2.7.14-1).
git is already the newest version (1:2.14.2-1).
The following packages were automatically installed and are no longer required:
android-framework-res android-libaapt android-libandroidfw
android-libbacktrace android-libbase android-libcutils android-liblog
android-libunwind android-libutils android-libziparchive junit libantlr-java
libantlr3-runtime-java libapache-pom-java libatinject-jsr330-api-java
libcommons-cli-java libcommons-io-java libcommons-lang3-java
libcommons-parent-java libguava-java libjaxp1.3-java libjsr305-java
libprotobuf-lite10 libsmali-java libstringtemplate-java libxmlunit-java
libxpp3-java libyaml-snake-java
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libpcap-dev
Requirement already satisfied: Twisted in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 1))
Requirement already satisfied: scapy in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 2))
Requirement already satisfied: bs4 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 3))
Requirement already satisfied: netaddr in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 4))
Requirement already satisfied: config in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 5))
Requirement already satisfied: dnspython in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 6))

Requirement already satisfied: iscdhcpleases in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 7))

Requirement already satisfied: netifaces in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 8))
Requirement already satisfied: pcapy in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 9))

Requirement already satisfied: configparser==3.3.0r1 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 10))

Collecting NetfilterQueue (from -r requirements.txt (line 11))
Using cached NetfilterQueue-0.8.1.tar.gz
Requirement already satisfied: configobj in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 12))
Collecting libarchive-c==2.1 (from -r requirements.txt (line 13))
Using cached libarchive_c-2.1-py2.py3-none-any.whl
Collecting python-magic==0.4.6 (from -r requirements.txt (line 14))
Requirement already satisfied: pefile in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 15))
Requirement already satisfied: capstone in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 16))
Requirement already satisfied: hyperframe in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 17))
Requirement already satisfied: h2 in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 18))

Requirement already satisfied: mitmproxy==0.18.2 in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 19))

Collecting scapy_http (from -r requirements.txt (line 20))

Requirement already satisfied: service_identity in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 21))

Requirement already satisfied: beautifulsoup4 in /usr/lib/python2.7/dist-packages (from bs4->-r requirements.txt (line 3))

Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from iscdhcpleases->-r requirements.txt (line 7))

Requirement already satisfied: enum34<2,>=1.0.4 in /usr/lib/python2.7/dist-packages (from h2->-r requirements.txt (line 18))

Requirement already satisfied: ipaddress>=1.0.15 in /usr/lib/python2.7/dist-packages (from mitmproxy==0.18.2->-r requirements.txt (line 19))

Requirement already satisfied: typing>=3.5.2.2 in /usr/lib/python2.7/dist-packages (from mitmproxy==0.18.2->-r requirements.txt (line 19))

Building wheels for collected packages: NetfilterQueue
Running setup.py bdist_wheel for NetfilterQueue ... error

Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;_file_='/tmp/pip-build-UpUDgo/NetfilterQueue/setup.py';f=getattr(tokenize, 'open', open)(_file_);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, _file_, 'exec'))" bdist_wheel -d /tmp/tmpOoR1Uipip-wheel- --python-tag cp27:

running bdist_wheel
running build
running build_ext
building 'netfilterqueue' extension
creating build
creating build/temp.linux-x86_64-2.7

x8664-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -DFORTIFYSOURCE=2 -g -fdebug-prefix-map=/build/python2.7-VlMpWk/python2.7-2.7.14=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I/usr/include/python2.7 -c netfilterqueue.c -o build/temp.linux-x8664-2.7/netfilterqueue.o

netfilterqueue.c:437:10: fatal error: libnfnetlink/linux_nfnetlink.h: No such file or directory
#include "libnfnetlink/linux_nfnetlink.h"
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

----------------------------------------
Failed building wheel for NetfilterQueue
Running setup.py clean for NetfilterQueue
Failed to build NetfilterQueue
Installing collected packages: NetfilterQueue, libarchive-c, python-magic, scapy-http
Running setup.py install for NetfilterQueue ... error

Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;_file_='/tmp/pip-build-UpUDgo/NetfilterQueue/setup.py';f=getattr(tokenize, 'open', open)(_file_);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, _file_, 'exec'))" install --record /tmp/pip-Jta1yj-record/install-record.txt --single-version-externally-managed --compile:

running install
running build
running build_ext
building 'netfilterqueue' extension
creating build
creating build/temp.linux-x86_64-2.7

x8664-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing -Wdate-time -DFORTIFYSOURCE=2 -g -fdebug-prefix-map=/build/python2.7-VlMpWk/python2.7-2.7.14=. -fstack-protector-strong -Wformat -Werror=format-security -fPIC -I/usr/include/python2.7 -c netfilterqueue.c -o build/temp.linux-x8664-2.7/netfilterqueue.o

netfilterqueue.c:437:10: fatal error: libnfnetlink/linux_nfnetlink.h: No such file or directory
#include "libnfnetlink/linux_nfnetlink.h"
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

----------------------------------------

Command "/usr/bin/python -u -c "import setuptools, tokenize;_file_='/tmp/pip-build-UpUDgo/NetfilterQueue/setup.py';f=getattr(tokenize, 'open', open)(_file_);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, _file_, 'exec'))" install --record /tmp/pip-Jta1yj-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-UpUDgo/NetfilterQueue/

----------------------------------------
= checking dependencies
----?----+ hostapd Installed
----------------------------------------

  • Distribution Name: Kali

----------------------------------------
= Install WiFi-Pumpkin
? binary::/usr/bin/
? wifi-pumpkin installed with success
? execute sudo wifi-pumpkin in terminal

  • P0cL4bs Team CopyRight 2015-2017
  • Enjoy

and then when i tried to start wifi-pumpkin

it said

root@kali:~# wifi-pumpkin
Traceback (most recent call last):
File "wifi-pumpkin.py", line 37, in <module>
from core.utility.application import ApplicationLoop
File "/usr/share/WiFi-Pumpkin/core/utility/application.py", line 3, in <module>
from core.main import version
File "/usr/share/WiFi-Pumpkin/core/main.py", line 28, in <module>
from core.widgets.tabmodels import (
File "/usr/share/WiFi-Pumpkin/core/widgets/tabmodels.py", line 15, in <module>
from plugins.analyzers import *
File "/usr/share/WiFi-Pumpkin/plugins/analyzers/image.py", line 5, in <module>
from scapy_http import http
ImportError: No module named scapy_http

please help me guys.................
sorry if i wasted your time :(

Get The Null Byte Newsletter

Never miss a new hacking or security guide

5 Responses

what do i write in the terminal bro

still i couldnt do it please hlp

oot@kali:~# wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -
key 7721F63BD38B4796:
1 signature not checked due to a missing key
OK
root@kali:~# apt-get update
Get:1 http://deb.i2p2.no unstable InRelease 12.3 kB
Err:1 http://deb.i2p2.no unstable InRelease
The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 67ECE5605BCF1346
Reading package lists... Done

W: GPG error: http://deb.i2p2.no unstable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 67ECE5605BCF1346

E: The repository 'http://deb.i2p2.no unstable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
root@kali:~# ^C
root@kali:~#

please help me to solve this problem. any pro is here ? i am trying to fix this from 2 months....
wifi-pumpkin
Traceback (most recent call last):
File "wifi-pumpkin.py", line 37, in <module>
from core.utility.application import ApplicationLoop
File "/usr/share/WiFi-Pumpkin/core/utility/application.py", line 3, in <module>
from core.main import version
File "/usr/share/WiFi-Pumpkin/core/main.py", line 24, in <module>
from core.utils import (
File "/usr/share/WiFi-Pumpkin/core/utils.py", line 9, in <module>
from scapy.all import *
File "/usr/local/lib/python2.7/dist-packages/scapy/all.py", line 10, in <module>
from .config import *
File "/usr/local/lib/python2.7/dist-packages/scapy/config.py", line 11, in <module>
from .data import *
File "/usr/local/lib/python2.7/dist-packages/scapy/data.py", line 184, in <module>
TCPSERVICES,UDPSERVICES=load_services("/etc/services")
File "/usr/local/lib/python2.7/dist-packages/scapy/data.py", line 109, in load_services
f=open(filename, errors='ignore')
TypeError: 'errors' is an invalid keyword argument for this function

Share Your Thoughts

  • Hot
  • Active