Forum Thread: Kali Linux "apt-get" error / dpkg error

Hi, I'm pretty new here and quite a noob.

I've gotten myself a Raspberry Pi 3 recently and tried installing Kali Linux. I went to the "offensive security" homepage to download the iso for the raspberry pi, flashed it onto a sd card and put it into my raspberry pi.

Everything boots up perfectly normal.

But once I try to run "apt-get install gparted" or any other other extension than gparted or even only when I run "apt-get install upgrade" my system donwloads all the stuff but when unpacking it suddenly shuts down. When I reboot it, it reboots perfectly fine but once I try to use "apt-get upgrade" again it says "dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem. Once I do this, I get the following Error: "failed to open package info file '/var/lib/dpkg/updates/0400' for reading: Structure needs cleaning".

Things I already tried:

  • deleting Kali-Linux from my SD-Card, flashing it again (like 20 times)
  • deleting /var/lib/dpkg/updates/ but it can't finish deleting since 1 file always needs cleaning (always a different one)
  • changing my sources to "http://repo.kali.org/kali" with repo instead of http

Can't seem to get it working. I'd really apreciate if someone can help me !

Get The Null Byte Newsletter

Never miss a new hacking or security guide

Be the First to Respond

Share Your Thoughts

  • Hot
  • Active