Forum Thread: Kali Log in Screen Help?

I was trying to download PHP5-cgi and failed each time. I eventually gave up and shut off my machine to go get some rest. When I turned it on later I was shocked by this (see picture below) and I do not know what to do or what this is even called. Please help me as I am a learner trying to capture anything that will help my intelligence in this area increase. (Macbook- Virtual Machine Run by VMware Fusion)

9 Responses

I have never experienced this one before. I mean, you could just get a new image of kali and install that.

Did you try startx

Yes, command not found

apt-get install x-window-system

Thank you so much! I realized what was wrong after the apt-get wasnt working! You guys are the best!! Thanks DILL!

What was wrong? Just curious.

Well I accidentally added a source to my /etc/apt/source file and when I tried to download files from that It changed my source file completely. So when I backtracked my steps I found this edited file and replaced it with a default one. Then I ran the apt-get install x-windows-system, typed startx and viola! Only thing is, It seems like everytime I reboot I have to type the startx in that terminal line again

If you changed the source list and it caused you this issue when you downloaded from it then I would seriously consider rebuilding Kali. Who knows what else this source has done to your machine. It is my personal recommendation to be extremely careful when adding to the source list, you may easily be the victim, and it's known to break kali installs. http://docs.kali.org/general-use/kali-linux-sources-list-repositories

just type gdm3

i actually prefer using Kali this way, because it is easy to perform short tasks, and if i want the desktop environment, i just type gdm3 in the terminal

-Phoenix750

Share Your Thoughts

  • Hot
  • Active