Forum Thread: Metasploit Meterpreter--> Acces is denied

I succeeded in obtaining a meterpreter session with my other computer but when I was searching through the Directories by using the commands cd and ls everything went according to plan untill I came across "My documents". I could use cd My documents and it worked out but when I tried "ls" afterwards it gives me: stdapifsls: Operation failed: Acces is denied.

Does anyone know how to solve this problem?

4 Responses

Well it seems you need more privileges... to do these kind of actions. Depending on what OS you are attacking you have to find another exploit of some kind to expand your privileges (privilege escalation). So find an exploit for the victim specific OS and use the meterpreter background feature to use more exploits.

I had the same issue when I was testing stuff myself and I got stuck searching for a W7 64-bit exploit. I wanted to try and disable the AV and/or the firewall but I got "access denied".

Also, don't forget the getsystem command!


If ls doesn't work within meterpreter, type:
cd <path to directory>
If it doesn't work, you'll need privilege escalation.

Not sure if anyone will read this but anyway

I am having trouble accessing my pc's USB webcam...
I connected with reverse-shell and am getting NT Authority with getuid

Every other command than webcam-anything- works properly as if I had the privileges. I can't figure out what I am doing wrong

Share Your Thoughts

  • Hot
  • Active