Forum Thread: payload_inject and Processes Shown in Meterpreter

payload_inject and Processes Shown in Meterpreter

Hi. I have gotten a meterpreter session on my W8.1 x64 machine. I cant use getsystem and some other good stuff and i figured it was because of the meterpreter being x86. So I wanted to use payload inject to get a x64 meterpreter instead, which failed because it could not get a proper PID. When i use ps in meterpreter it shows very little processes. Where am I going wrong?

http://postimg.org/image/le11s3lxj/

11 Responses

How did you infect the target ? Because I only see webbrowser or Notepad.
I guess you used a web exploit.

When I tested such infection with Hacking team Flash Exploit, the remote session only has access to firefox associated processes and not to the users one.

Try to upload an executable on the hard drive and launch it via cmd from your meterpreter.

Or upload an trojanized exe , and launch it manually in your target.
See the differences :)

Typically you could migrate to the explorer.exe which is x64 and having fun :)

Thanks for your reply.

I used browserautopwn. Im pretty sure that when I used that same exploit on XP and 7 x86 it gained access to all processes but I might be misremembering. Can't test it because I deleted those VMs. I thought about uploading an executable payload but I was afraid AV would pick up on that, and I was not sure if I could disable AV services without a system account. But since that is also done from cmd (i forgot about that part) i guess it will work :)

I haven't tryed this on Windows 8.1, but you could try to use:

msf> use exploit/windows/local/bypassuac

This is like a post exploit, you need to have an active session, then background it and launch the exploit.

The setting are quite easy, first set SESSION (your active session ID), then create another payload and set your LHOST and an alternative LPORT, for example I change it to 5555, you can't run two payloads on the same port at the same time.

Also make sure to set the target, you have two options, x64 or x86.

Then just exploit and see if successful. If everything is fine you should manage to use the 'getsystem' command and get full control on the target.

Let us know if it worked.

Good luck!!!

Thanks for your reply. I actually think I tried that, can't remember for sure, so I will definitely try that again :). If I did, I probably did not change the target. Did not know i had to use another port. I will get back with the results.

Unfortunately it returned: Exploit aborted due to failure: no-access: Cannot BypassUAC from Low Integrity Level.

Typically you re into the browser session , which is different from the user session.

Browser processes are in your case Low integrity , very low power of action.

User processes are in medium integrity , and if the User is local admin , you can use bypassuac function which uses Dll Hijacking to spawn a High Level Processes.

High Level Processes are processes from NT Authority/System , if you can migrate into one , you are the king on the infected system.

Av are easy to bypass :) : Keywords Veil-Project / Shellter.

Have Fun :)

Oh i see. Thank you very much for the explanation. I was convinced that meterpreter just "took over" the system whichever way it entered :). I will look into that. Thanks :)

Clearly no :) , having a remote control is far away from pwning the system.

You can have fun with a simple meterpreter , but with admin privs aka High Process integrity meterpreter you control the entire machine , persists into it and do full of bad (cool) stuff ! :)

Be Fun , Be Ethic

I just complicated things for myself when there was a simple explanation :).

Indeed. Had full control over my XP VM and that was way more satisfying. I guess I used a specific exploit on that. I suppose social engineering is the way to go for real world application, atleast for full control. Autopwn was a nice fantasy :).

Yep , if you're interested in browser attack, i can lead you to study the Beef framework , or some drive-by attacks such as Trojan firefox plug-in :).

Have fun :)

Thanks again. You have been most helpful! :)

Share Your Thoughts

  • Hot
  • Active