Forum Thread: Problem Opening Msfconsole or Metasploit in General

When Trying to Open Msfconsole

Recently I have updated Kali and after it was finished updating I went to go open msfconsole and got this error.

I am generally new to using msfconsole, but I did do research to find an answer to this, I am not just relying on you guys to help me with everything. I looked for an answer for a couple of days before posting but I couldn't get it to open up. I tried updating ruby and metasploit but that did not work so i need some help finding a solution. I also tried running bundle install and got this:

I don't know if I am making a beginners mistake but I looked on many forums and articles and could not find anything that helped, so could I please get some help thanyou!

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

2 Responses

try typing exit and then running it as root. Otherwise find out how to run a not-root terminal in Kali. or create a temporary user with no sudo privileges and run bundle install.

Share Your Thoughts

  • Hot
  • Active