Forum Thread: Problem with rt3070 Chipset in Kali

Problem with rt3070 Chipset in Kali

Hello readers,

How is everyone? I'm a little moody.

So i installed Kali Linux 1.0.9(Debian) on Virtualbox and I bought an USB wireless adapter AWUSO36NH with chipset rt3070.

Installing

I installed the rt3070 windows driver for my host windows 7 OS: http://www.powerwifi.nl/nl/drivers
On my VM I installed the rt2870sta driver for linux:
http://www.mediatek.com/en/downloads/rt2870usbrt2870rt2770/
From there I did the following:

  1. I ran the apt-get update & apt-get isntall linux headers commands.
  2. I blacklisted the rt2800usb and changed WPASUPPLICANT & NATIVEWPASUPPLICANT to = Y'
  3. I changed few other settings to succesfully run the 'make & make install' commands, and i did 'modprobe rt2870sta'.
  4. I installed the mod 'insmod rt2870sta.ko' and rebooted.

Problem

So from the several tutorials that i read on installing the drivers, it would seem like I installed the drivers correctly and should be able to use my adapter on Kali. But when I start up Kali from my VM, connect my usb adapter and disconnect it from my host OS, it doesn't seem to work.

root@kali:~# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

root@kali:~# iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

When i go to settings>devices>usb-devices it shows that my Ralink 802.11n WLAN0101 is connected.

I honestly have no clue on what I may have done wrong. I hope you guys can help me figure this out.

21 Responses

I have the same card (I guess that O is a 0?) and it works out of the box, without installing anything.
It also works with VirtualBox with me out of the box, so I don't really understand why it's not working.
Iwconfig shows no wlan0 interfaces?
Does it tell you "Device not managed" when you try to connect to an AP?
In that case edit with nano:

nano (WRONGFILE, edited, right one is /etc/NetworkManager/NetworkManager.conf)
And edit the file like this:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true

If not, the problem is somewhere else.

Sounds like you deleted you wirless drivers somehow during installation. What is your wireless driver

Hey CIUFFY thanks I appreciate your help.

iwconfig indeed shows no wlan0 interfaces.
And yes, when i click on the computer at the top right of Linux, it shows:
Wired network and below that
device not managed
VPN-connections

I edited the /interfaces file and replaced the code with yours.

All that did was put a little red cross next to the computers at the top right, where it still says "device not managed" unfortunately.

Let me provide you with some alternative settings of virtualbox, might that be of any help:

  1. I assigned the virtualbox 1 CPU, since I read on forums that assigning it multiple CPUs would not work with USB adapters.
  2. I set my network to 'network bridge adapter' and there listed my USB adapter as name.
  3. In Settings>USB I filtered my adapter.

I also read this thread https://forums.virtualbox.org/viewtopic.php?p=176270#p176270

Perhaps i should try that?

I don't think that will be helpful, but if it matches your situation, try that.
I was indeed wrong, very sorry, the file you must edit is not that, but /etc/NetworkManager/NetworkManager.conf

So, so, so sorry about that (I was in a hurry), but you are on VM on a live installation, so you probably don't care about retrying (I hope...)?

You'll also have to:

service network-manager restart

BTW: for future reference, this is the article by "BlackMoreOps" (there's tons of them, just selected the most detailed) that I follow every time I have that problem, so if you want a better explanation, there it is.

No worries about that :)

But just in case, does this mean all the other settings which I told you about in my previous posts in both VM manager and Linux are done correctly?

edit By the way that tutorial on "BlackMoreOps" only shows how to fix the "device not managed" problem. At the end of that tutorial (when he did iwconfig) the wlan0 still didn't show up.

1) I don't know about the CPU thing, I know that I didn't change anything, only installed the USB support because my version didn't have it, but since yours is recognizing the USB adapter, afaik it doesn't really matter.

2) Again, I used the default options and it worked out without problems, the only one is the one I showed how to solve. I did hear about this one, but don't really know.

3) If by filtered you mean clicked on your USB adapter, then it's correct :)

Again, I've been using a slightly different version of VB, so settings might be different, but I?m sure about the "device not managed thing". As I said, if it doesn't solve, the problem is somewhere else, probably in those two configurations you mentioned, I'll be reading about them.

EDIT: If you want to be sure, start from a fresh VM and first try my solution, then apply those 2 points.

Sorry, your last edit, does it mean it didn't solve the problem?
It is because there is no wlan0 until you plug in the device.

Try to network-manager restart after plugging in the wireless adapter, I'll try to reproduce the process too, so I'll be able to tell you what the problem is.

Hey,

So i started from a fresh VM, i did the install and got the vb guest additions. Then I changed the NetworkManager.conf file, and it worked! Im connected to Ifupdown (ethO). In the 'blackmoreops' it said I should now be able to connect to a network and browse the internet, but even before the "device not managed" problem I was allready able to acces the internet. I don't know if this is relevant in my case, but I just wanted to let you know that accessing the internet wasn't the problem in the first place.

My USB is recognized but still the commands "lsusb" and "ifconfig & iwconfig" don't show my usb device or a wlan0 network being available. I unplugged it and plugged it back in, still nothing happened. I do stay connected to ifupdown eth0 though.

It seems like Linux can't find my usb device, even though it says it is connected.
usbmodeswitch -v 148F -p 3070 also shows that it can't find my device.

Have you had any luck reproducing the process?

Useless considerations. you can skip this...
Yes, I had luck reproducing this, this was my setup:
-Kali 1.0.7
-Virtual Box on Mac (I can't try this on Windows right now).
This time I didn't have to edit NetworkManager.conf, I just plugged it in and it worked.
Just to know, what kind of Virtual Box version do you have? I'm currently using 4.3.16.

Because: the problem might be VB not having USB support at all, I had to download a VB extension first...doing some tests right now.

Interesting part, adding USB support
Oh, just found out, trying on my own, that filtering it doesn't really help!

You have to go to Virtual Box official web site and download the extension pack for your VB version, then install it, run VB, run Kali VM and in the main top menu go to Devices->USB Devices->Your wireless adapter.

And this works for me, and in most recent versions you probably won't even need to edit NetworkManager

Sorry for not telling you before but I was told that some recent versions have USB support incorporated (well, probably not then), and I thought that for USB filtering you meant this operation.

I am running VB 4.3.12 (don't ask me why), but I downloaded 4.3.16 now. I used Kali 1.0.9a, but if that still doesn't work with 4.3.16 VB, I'll try and download the 1.0.7 version. I'm going to try this setup and will edit this post and report back when I'm finished. Thanks

It's not a matter of Kali version nor VB, just try with the Usb support and the extension pack and report the results.

I downloaded VB 4.3.16 with the right extension pack, but when i plug in my usb adapter, while on kali vm, I get the following error:

the instruction at 0x00000000 referenced memory at 0x00000000. A read or write operation on the memory failed: written.
Click OK if you want to end the program.

Then my host OS started to install drivers for this usb: "USB Virtualbox"

I looked up this problem but as always there can be multiple causes for this error.

So, you get that error in the host OS or Kali VM?
Never heard of that...

Did you install extension pack correctly? Does this happen as soon as you plug the usb in the computer or after you go into Devices->USB?

Just trying to figure out what is happening.

Ok so I start up Kali VM, logg in as root and when it's all properly loaded I plug the usb in the computer. I see that in the bottom right It's connecting to the VM, but after about 5 seconds I get the error and VM shuts down. So the error appears in Kali VM.

Kali VM functions normally untill I plug in the usb. I also tried plugging in the usb before starting the VM but that made no difference.

Extension pack is installed correctly and It's the right version.

I honestly have no idea what's going on, but I'll tell you something:

A live CD installation would solve all of your problems. Or at least, will confirm that this is a problem related to windows and Virtual Box.

What I'm talking about (just assuming that you don't know) is booting from USB or CD. This will make it a lot more stable and a lot more easy to use with the wireless adapter, as it would easily work without any problem (if you get errors, that's because of the computer itself, kill it).

As you go on with you exploration of Kali Linux you'll notice that a virtual machine is slow, buggy, not portable and practically useless.

You have to feel the penguin, not the penguin in the window, because Windows are a far conception in this igloo world.
Ok, I tried the joke, that didn't work out very well.

Read my post here to see if you are familiar with what I'm talking about. Tell me in private message (or post publicly, so that everyone can answer) if you find any problem.

However, if you still want to use Virtual Box, I'm currently working on it while I wait for your response.

I too had no idea what was going on haha. Soooooo, i downloaded version 4.3.12 of VB, along with the extension pack, and guess what?

It worked!! My usb is being recognized so finally all this trial-and-error is over. I honestly have no idea why it wouldn't work on 4.3.16 but is working on 4.3.12. But I can finally start learning about kali now!

Anyways, thank you very very very very much for your help, I really appreciate it :)
Happy I can finally continue and end this thread.

SO Glad it worked!

However! Consider the idea of using a Live CD and in future a persistence USB maybe, because you'll soon find yourself in small space, when things get more interesting.

But first, enjoy your VM ;)

Victory.. Good work and patience CIUFFY. If I can't get something to work I'm calling on you.. Was as simple as using a current software build. As complex as putting a watermelon through the eye of a needle 8-)

Thanks!
Actually it's more likely me calling you for sure ;)

Share Your Thoughts

  • Hot
  • Active