Forum Thread: ProxyChains Problem

ProxyChains Problem

Hey guys, i have a new problem with ProxyChains and i think i fix other one. When i type ' proxychains iceweasel ' to terminal, an Iceweasel browser opens but everything is same and i got this on terminal (process:6454): GLib-CRITICAL *: gslicesetconfig: assertion 'syspagesize == 0' failed How can i fix this?

28 Responses

Hmmm, I don't know. I am going to ping OTW and have him look at this since he is the local professional.

I will be very thankful, thanks :)

In the mean time you should check spelling, syntax and formatting of the config file.

I tried they already, they did not fix :&
note: sorry for bad English :(

Send me a screenshot of your config file and the commands you are running.

http://paste2.org/1ccbUeF4 this is my config file and i am just writing 'proxychains iceweasel'
note: i tried with firefox too, nothing changed

Try looking at the proxies you added and the format OTW showed to add proxies and see if you can find it.

My proxies are working i think, i found that at hidemyass.com and i check them in samair.ru. Yes i read it, it was my first problem :D

Ok well if you fixed the syntax issue than it should work

i have suffered the same problem when i use kali 2.0. i found a gnome shell extention called proxyswitcher, and i turn it off. at the end, i use iceweasel preference ->advanced->network->setting to set a proxy, it works

Yes, i find that too but with this way you can use just one proxy and you are not anonymous clearly :%

go to iceweasel preferences, advanced, network, connection settings... check manual proxy configuration
add 127.0.0.1 as SOCKS Host, and port 9050
check SOCKS 5 and Remote DNS
hit OK
now type: service tor start
then: proxychains iceweasel www.canyouseeme.org
see if your ip changed

Hello, thanks for reply. When i type ' service tor start ' i have an error. "Failed to start tor.service: Unit tor.service failed to load: No such file or directory." If i type proxychains iceweasel a new tab opens and i can't surf. http://imgur.com/28bRyRp this is the error.

do you have tor installed? if not do that by typing
apt-get update && apt-get install vidalia tor tor-geoipdb polipo

I installed tor, but i have same error :/

Don't only use TOR, it is not perfectly secure.

I am downloading Kali Linux 1.1 now. I hope it will fix my problems. I cannot use ProxyChains, i have always an error.

Did you find and fix that typo? Or is this giving you a different error?

I think yes, i fix it. Exactly i have this error all the time but i was ignored, now i have only this :&

I've got the exactly the same problem, any ideas?

Please show us a screenshot of your config file. Also, did you use a tab between proxy type and IP address?

Hi Pawel Mazur try to give two tabs beetween type of proxy and address, like put it line with the tor example ;)
Tell me if it works Hope it helps ;)

Dear Berk !!
Please remove your customized proxies also remove # from socks4 @ 127.0.0.1
Also add socks5 127.0.0.0 9050
It 'll work :D

Hello I have a probleme with proxychains that I modified proxychains.conf by adding socks5 127.0.0.0 9050 but the probleme is with firefox that when

# proxychains firefox www.duckduckgo.com
the page keep in resersch and nothing in end

Hi,can you help me with proxychains
?

when I write "service tor start" to start the service I get this error "Failed to start tor.service: Unit tor.service not found."

help anyone,
i put many proxies in /etc/proxychians.conf in proxy list.
when i start the service by , service proxychain start
it show this error
Failed to start proxychains.service: Unit proxychains.service not found.

Share Your Thoughts

  • Hot
  • Active