Forum Thread: Question about Mitm attack

Question about Mitm attack

I am trying to do a mitm attack on my own network. I am using Kali linux 2.0 in vmware on a laptop. I used arpspoof -i eth0 -t (VictimIP) (RouterIP) and it started running. However when I tried to browse on the victim machine internet didn't work anymore. This made me draw the conclusion that this had been the case because of using eth0 on a wireless network. Therefore I used a network usb adapter (wlan0). When I used arpspoof again: arpspoof -i wlan0 -t (VictimIP) (RouterIP) it didn't start running but it said: Arpspoof: couldn't arp for host "VictimIP"

I tried several different IP's but it didn't make any difference. I can also say that wlan0 isn't in monitor mode but in managed mode.

Is there anyone who could help me out with this problem?

10 Responses

Here is an accurate explanation of your situation, with which I must agree.

TRT

I know that but it still doesn't explain the error I get when using wlan0. When I used eth0 I did spoof both router and victim but then still the victim wasn't able to get on internet. Therefore I used wlan0 and when I tried running the command again it already gave me an error when I only tried to spoof the victim

> arpspoof -i <interface> -t <target> <gateway>
> arpspoof -i <interface> -t <gateway> <target>

That is what you should've done. If by any chance you repeated the first command (i.e. didn't switch the target and gateway the second time), that could be your issue.

TRT

I did do that and I used interface eth0 while I am on a wireless network. Nevertheless my problem is that both commands start running without any problems but my victim can't use internet anymore. I also ip forwarded so that can't be the problem.

Is your interface in monitor mode? Monitor mode conflicts with ARP requests and can cause great confusion when performing such attacks.

TRT

No it's not but I thought eth0 didn't work because I am using a laptop on wireless network. I can't even put eth0 into monitor mode but I can put wlan0 in monitor mode. Therefore I used wlan0 (not in monitor mode) but that gave me the error couldn't arp for host <victimip>

Are you sure that you entered the correct IP address for the victim. Use nmap to check if the victim is up, but turn off ping (-Pn). Make sure both the target and gateway are reachable.

TRT

Yes because I am doing this in vmware so I am trying to attack my own laptop from vmware. Probably something is wrong with my Wlan0 configuration because it doesn't have an IPaddress. Wlan0 is an usb-adapter and when I am trying to get it configured with forexample ifup wlan0 it keeps asking for an ip but for some reason it doesn't get it.

Why didn't you mention that straight away? That is exactly the issue. Please provide the output of ifconfig and maybe things will get less misty.

TRT

Sorry I wasn't aware of that problem yet because I used the same adapter for Wifi hacking with airodump and that worked perfectly fine. I need to update the drivers so that's what I am going to do. Thankyou for helping me.

Share Your Thoughts

  • Hot
  • Active