Forum Thread: REAVER Not Working on Kali 2.0?

REAVER Not Working on Kali 2.0?

I already posted this question a couple of weaks ago but got no solution. So here I am posting it once again with the belief that this time some expert would be able to help me rectify this god-awful problem that's been bugging me for the last couple of months.

The thing is when I try to start a pin cracking session with REAVER against any AP, it gives an error "Failed to Associate with this BSSID". Now don't tell me that its some default settings in the AP that is preventing the reaver attack because I have tried it against around 15 APs and found no luck against any of them. Plus the old Kali 1 works fine against all of them. Its just the new Kali 2.0 that never allows me to associate with the AP.

And the OS is already fully updated.

6 Responses

So, should we tell you to use Kali 1.0?

Kali 2.0 has a pretty nice interface plus I want to abandon the old Kali since every one else has already transitioned to the new one. Do you have a solution for the question asked above?

First, not everyone has transitioned to Kali 2.0. Many people are still using Kali 1.1 or earlier, because they work. Second, if an OS is not working for you, the pretty interface is a heavy price to pay. Third, since I'm not using Kali 2.0 and won't until all the bugs are worked out (I don't care how nice the interface is), I have not experienced this issue.

is this topic is still on ? i may help here if anyone interested!

Im having the same problem. I just upgraded to kali 2016.1 from 1.1.0. I am running kali from a live usb. In kali 1.1 reaver worked fine but now in the new kali reaver is stuck on waiting for beacon and gives messages saying it failed to associate with the AP. Please help..

Bruh, i have the same problem, this sucks .-.

Share Your Thoughts

  • Hot
  • Active