Forum Thread: Rooting an Alcatel Android

Rooting an Alcatel Android

Hi… I have just got an Alcatel Pixy 33.5 4009D (also named TLC 4009D) with android 4.4.2 and I tried all most common rooting apks like: kingoRoot Kingroot towelroot plus some chinese ones that I don't even know what do they do all with the promise to work.

Unfortunately none of the above work, I don't know is something that I am missing? I also installed Super User, SuUser fix etc but no luck.

I appreciated some help now.

4 Responses

Use the PC version of Kingo root and connect with usb cable...also enable USB debugging on the phone

Yeah… tanks I have done it with the original cable and I have change the settings using the developer mode with usb debugging and allow the downloads from apps other then google… I don't know, goes up to 77% and then dies. One app told me that I have a very hard to crack phone!

Do you get any error in particular? Kingo root never fails me....

No at first now I got: ERROR CODE: 0x1CE957 but still no plan suggested.

Share Your Thoughts

  • Hot
  • Active