Forum Thread: Selenium won't run due to geckodriver error

While running a script, it says selenium is installed but once the script runs (python setup.py) I receive an error:

chmod: cannot access 'geckodriver': No such file or directory
see attached picture of full error. I am running Linux 32 on VMware player 32bit

I've already ran an apt-get update and tried updating the geckodriver to the latest v0.19.1, no luck there either. I've also manually installed geckodriver and updated Mozilla putting them in the same folder as my script and selenium still doesn't seem to pick it up. Selenium is installed but once I need to run it, I get Error 404

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

4 Responses

Still getting error 404 no such file or directory

I was able to change the script to use the latest version of geckodriver and seems to have worked. But now when I run the script selenium won't access the webdriver. I currently have Firefox ESR. I've tried to apt-get install firefox but get an error that no installation candidate available. How can I get selenium to access my webdriver

Do you have suggestion about implementation of such code in the Windows environment?
When I'm trying (chmod +x geckodriver) this error is occurred:
chmod: cannot access 'geckodriver': No such file or directory

Share Your Thoughts

  • Hot
  • Active