Forum Thread: Trouble with "Ifconfig" Command in Kali

Hello. I have been having trouble getting the command "ifconfig" to work on my terminal. I do not have an external wireless card yet but plan on getting one. I know this may seem trivial. If anyone has any ideas please share. All ideas are welcome! Thanks!

Here is a error I receive:
admin@kali:~$ ifconfig
bash: ifconfig: command not found

I realize I am working under admin privileges and I did this for security purposes. I have also tried it under root and continue to get the same error.

Never Miss a Hacking or Security Guide

New Null Byte in your inbox, every week.

22 Responses

You Must Want To Understand Question For This Question Text is Enough..! Correct Answer is Provided By CyberHitchHiker

Greetings. The user account you are using /sbin is not part of its environment, perhaps.
Perhaps by typing the full path to ifconfig i.e. something like /sbin/ifconfig

That is a good first place to look, but he says it doesn't work with root, either. Let's get a screenshot of trying "ifconfig" with the root user.

Update: Thank you all for your help. I typed the full path with the root user and that resolved the problem. Thanks!

Flawless.

It'd be interesting to know if this happened in a brand new installation, so that we can maybe report some bugs, if it is even a bug.

"Update: Thank you all for your help. I typed the full path with the root user and that resolved the problem. Thanks!
2 months ago"

use msfvenom .
msfpayload is no longer in use.

msfpayload has been deprecated. Use msfvenom.

if u get like this commad not found just type like this
sudo ifconfig
and enter system password
add sudo before the command

You must have sudo previlegies.
sudo ifconfig

I can not type in my code... HELP..

You won't be able to see the password, but it's typing.

-bash: ifconfig: command not found
... no, seriously.
I'm root.
Tried sudo anyway.
Tried full path.
This is latest Kali Linux ARM for RPI1 - fresh/latest image d/l from OffSec website flashed to SDCard today.
Screenshot as proof (or self-reassurance I'm not going mad, you choose).

So I checked out the /bin/ (below)... nope. Likewise /sbin/ (I will spare you another screenshot, but trust.

Any idea what embarrassing oversight I have made?
Thanks in advance!

I had the same issue. In order to use the ifconfig tool, you need to install the net-tools package.
sudo apt-get install net-tools

hope this helps,
Tim

CAN YOU PLEASE TELL ME WHY WINE32 IS NOT WORKING IN MY KALI LINUX

i figured that the net-tools would have been installed after installing kali-linux-full

Thanks bruv ur a star i had the same problem was stuck for an hour hehehe

dileep@kali:~$ wine
it looks like wine32 is missing, you should install it.
as root, please execute "apt-get install wine32"
Usage: wine PROGRAM ARGUMENTS... Run the specified program
wine --help Display this help and exit
wine --version Output version information and exit
dileep@kali:~$ apt-get install wine
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
dileep@kali:~$ apt-get install wine32
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
dileep@kali:~$ sudo apt update
sudo password for dileep:
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
dileep@kali:~$ sudo apt-get install wine-development
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package wine-development
dileep@kali:~$ sudo apt-get install wine1.7:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package wine1.7:i386
E: Couldn't find any package by glob 'wine1.7'
E: Couldn't find any package by regex 'wine1.7'
dileep@kali:~$
please comeup with answer

Share Your Thoughts

  • Hot
  • Active