Forum Thread: Txpower Increase on Kali Linux Sana 2.0

Txpower Increase on Kali Linux Sana 2.0

Can anyone provde me with a way to increase the txpower in the new Kali 2.0 i cant seem to find a way to do it. All the old tutorials no longer work for the new version.

28 Responses

Try this:

ifconfig wlan0 down
iw reg set BO
iw reg get
(At this point play around with some country-letters, because BO provide me just 20 and US 30 on 2,4 GHz Freq )
iwconfig wlan0 txpower 30
ifconfig wlan0 up
iwconfig ( to confirm if new txpower is set )

If this doesn't work, try 'iw dev wlan0 set txpower fixed 30mBm'
instead of 'iwconfig wlan0 txpower 30'

It work's for me on the AlfaH but the adapter getting a little bit warm(maybe i'm just paranoid because of my phone charger).*

Bye

this no longer works on the newer versions of kali

i will try again

Image via imgur.com

-can you post your wireless-adapter?
-i saw a post here on null-byte some days ago. there someone explained
how to compile your own reg-set-rules.

as soon as i get home i will post the same screenshot and show you the results, and will give you the wifi adapter name, just weird for me that it stopped when i moved over to 2.0......

Thanks for your help so far

jahh, this aircrack-wifihacking-apadter-topic is very fragile and depends on many parameters. the curious about this, many people have different issues on similar requirements. if you just learn wifihacking for the sake of knowledge creat some eviltwin-man-in-the-middle-setups on your homelab. i like the mindset of "when it don't work i will stick on it till it does what i want" but as a person who just learn i would conduct my attacks over txpower of 20. someday you will need this attack for serious reasons and than everything changed because you maybe use kali 3.0 =)

in case of your goals are already specific than i would've said something.

anyway post something for me. but don't waste to much time on this. :)

and hey, if it works an kali 1.1 then use it in dual-boot. i guess most professionals use kali 1.1 or both till kali 2.0 will be updated and debugged.

to answer your question (weird): this depends on drivers, adapters (they can bought in GB but follow china-standards because their chipset was build there). the developers of aircrack are stick most on less chipsets. adapters -mostly the popular ones- can be replicas with different chipsets than you figured out and so on.

to be sure: you have done 'apt-get update && apt-get upgrade && apt-get dist-upgrade' ? my first move on any new installed distribution so i can't say if this is the reason. ;)

bye

yeah i always do an apt-get update && apt-get upgrade && apt-get dist-upgrade when i boot up.

I dont get the same result as you, as you can see below.
wifi adapter AWUS036NH

Image via imgur.com

I can dual boot like i do on my dsktop, but i would rather find a way to get this resolved so that i can only have the one OS, on my laptop.

no matter what country code i choose i get the same
00 World Regulatory domain

This is why i had to edit the CRDA file and change the 00 limit to 30 and then this was resolved but i just cant compile with the new versions :(

i have no idea, sry. but when i read through the boards many people seem to have the same problem.

1(i hope this is the problem). "iw reg set ISO3166-1alpha-2" than try again

i got this from here: https://fitzcarraldoblog.wordpress.com/2013/01/20/setting-the-wireless-regulatory-domain-in-linux-on-your-laptop/

i guess you already found this on yourself.

  1. type this commands:

"iw reg set IN"
"sed -i 's/^REG.=$/&IN/' /etc/default/crda"
"shutdown -r now"

from here: http://ubuntuforums.org/showthread.php?t=2259037

i have read something about corrupted regulatory.bin. search for this and try to get some information about it. tomorrow i will do the same.

good night

Well at least im not the only one getting this same issue, i will try your suggestions when i get home, thanks for all the help you have been giving me so far i really appreciate it mate :)

still doesnt increase the tx power :(

I'm wondering if someone on the old version of Kali, compiles the CRDA with the increase level of 30 on the 00 regulatory domain then import that into the Kali 2.o if it will work ?

i just noticed your on a different kernal than me,
You are on 4.0.4-1 Kali2
I am on 4.0.00-kaliamd64

i have done dist-upgrade also

I saw an articel which said that your Adapter can cause trouble, but i guess you need the n-standart right? your idea with compiling sounds goo, i would try it. load the package in kali 1.1 over apt-get source iw or an alternate source for the bin files. then apt-get build-deb iw. then cd in the dic and dpkg buildpackade. this will provide you a .deb file. maybe you have to ./configure , make , make install i dont know.

i also had an idea, but a very uncommon. i thought about our differences in system. your laptop has build in wifi, maybe you can try to disable it in bios an start kali live or install it again and then try again.

the last difference is county setting,but these should not impact on funtionality.

sry if this text ise confusing,bi hate to write on the.mobilephone =)

lol i know what you mean.
Yes my laptop has built in wifi and i use my external also.
MY laptop was configured for UK when i installed it.
I might try it in live and see what happens also.

I think i will see if i can load up my ESXi box with the old kali on it, plug my external wifi into it, and then try to compile the files, move them over to the new kali and see if the regulatory 00 will change to 30

this compiling and moving old files to new system didnt work , maybe i missed something :( back to the drawing board

could you try setting on 30 txpower on a different system with same adapter?(best choice would be a simple tower pc with just an ethernet-card)

when it (maybe) work's there your laptop(-hardware) cause the problems, else (maybe) the adapter won't cooperate.

sry, i'm out of ideas .

yes different system works fine :(
Worked perfect on this laptop until i installed kali 2.0

I'm working on something at the moment, i had an idea, will let u know how i get on.

hmm what i was trying didnt work, had to reinstall :( same issue, i have no solution for this at the moment and the pisses me off :(

in this case i'm relatively sure that you laptop-hardware itself cause the problems. My idea was that when you install kali on it and kali will install driver for your build-in-wifi automatically than this driver(-setting) maybe influence the drivers - or exact: the reg set - of your wifi-adapter.

So try to disable this buildin-wifi on bios or engineer it out of the laptop - after this, install kali again or boot live.

Along the way, my Linux-knowledge is not deep enough to confirm the benefits of this idea with facts. =)

well i found a solution there was a video guide on vimeo that showed the missing step, it was a dependancy i was missing and then as i suspected, changing the base CRDA level

Mine also not working at all. But my kali also up to date with newest( update, upgrade, dist-upgrade). But yet not working. What is that missing step and please give us that video link too and please share your knowledge with us. I'm tired following those old posts.

Thank you.

I got the same problem with a Kali 1.x version after installing an
updated Reaver with the pixiedust option. it may have something to do with the new airmon-ng that came with it.

WIFIUK can you link to the guide, because i am still having the same issue.

i couldnt find the video, but this is what i did to resolve the issue and get the increase txpower

apt-get install libnl-dev

#this line above might cause an error, so you will need to download the .deb from here https://packages.debian.org/squeeze/libnl-dev

also you might need to download https://packages.debian.org/squeeze/libnl1

apt-get install libgcrypt11-dev

you need to download these two files and put them on your Desktop Wireless-regdb and CRDA

extract each file into a folder with their name

tar xvjf {full name of your file}

in this step after you've extracted all files to their folders, go to the Wireless-regdb folder and right click and open up a terminal

nano db.txt

this will open the db.txt and you can edit it to your needs. you will notice the country 00, it is the world regulatory domain and that is applied before everything else so in this case you will have to replace those values with the ones for BO country. do that and then you can change (20) to anything you want like (30) or (33). if you want to use 5.8Ghz channel, change both values. 33 dBm gives you 2W so i assume you know what that means.

go back to Wireless-regdb directory and edit the makefile, on kali linux 2.0 you need to remove the /usr on the /usr/lib/crda on the 3rd line down.

Then save it and then do a "Make" in the same folder. this will create some additional files including regulatory.bin that we need.

copy the regulatory.bin file to /lib/crda directory and replace it but if you want you can backup the original file before replacement.

Go to /lib/crda/pubkeys and copy benh@debian.org.key.pub.pem to /Desktop/crda-1.1.3/pubkeys/benh@debian.org.key.pub.pem

PART 1

PART 2

exit the folder and go back to Wireless-regdb folder on your desktop and find all files with extension of (.pem), copy them all and paste them into crda-1.1.3/pubkeys folder on your desktop.

now it's the last step, go back to your crda-1.1.3 folder in terminal and type these commands

make

make install

after that restart your computer and do an iwconfig and you'll see your new TX power. if after restart the changes didn't take effect do a make install in Wireless-regdb directory too but i don't think that would be necessary at all.

This resolved it for me, remember to only add power that the wireless adapter can take, in my case its the ALFA AWUS036NH

Share Your Thoughts

  • Hot
  • Active