Forum Thread: Unsecure Network, Access to Printer, Now What?

I am on an open wifi network. The gateway I am connected to , 192.168.1.1, has a secure network behind it at gateway 192.168.11.1. A series of Nmap commands painted me a picture of the network, to include CCTV server, POS system, and a computer. Some more digging and I was able to open up the network printer in browser. It has no admin password. I can see the WPA passphrase on the website, but it is dotted out. Using the network printer, how do I access other computers on the network, see the WPA passphrase, or do anything really. Metasploit has been unable to open any session. Is this because the network I am trying to exploit is two hops away? Any help is appreciated. Thanks.

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

6 Responses

I've looked at IoT devices before. You need to determine if there are open ports on the device. Start with nmap or netcat. The next thing I would do, is try to get a firmware update from the manufacturer. Here you can extract the password hash for telnet, ssh, etc, out of the etc/passwd or etc/shadow.

Then if you try to connect via SSH/telnet, using the password (if there even is one), and bobs your uncle.

It is probably running BusyBox, so it isn't like you can just apt-get stuff to put on it, but you can compile binaries on your PC and transfer the money to it over with wget or something else.

I'd be shocked if you weren't able to get a root shell.

Appreciate you reaching out to me. I really can't get an exploit going. I believe because I am accessing the host through their wifi proxy router. How do i configure metasploit to support and make a payload work.

Here is what i would do. I would use an evil twin attack to find my way into the network which is way easier that brute forcing a WPA handshake. Once inside my main course of action would be a Man In The Middle attack. From here it will be a matter of hooking their browsers on the fly and getting a more or less temporary session on Metasploit that will give me enough time to upload a custom backdoor.

Or i could just hijack their downloads and and get my malware in, in the form of trojans.

But if you do manage to find another juicy vulnerability from your nmap scans, go for it first before attempting the above.

;) actions have consequences

I'm not new to such devices but have you tried opening ports of the device maybe you could find something!!

I've tried and tried. Lots of open ports, I even managed to find a vulnerability in the internal network router and downloaded the config file, but still no luck. Config file did not include any credentials to get on the private network. Metasploit cannot get a session open. The victim hosts are behind a second gateway.

Share Your Thoughts

  • Hot
  • Active