Forum Thread: MITMf Error

error running MITMf

#python --spoof --hsts --arp --appoison -k -i wlan1 --gateway
No specific target.

Traceback (most recent call last):
File "", line 37, in <module>
from plugins import *
File "/root/MITMf/plugins/", line 20, in <module>
from plugins.plugin import Plugin
File "/root/MITMf/plugins/", line 22, in <module>
from core.configwatcher import ConfigWatcher
File "/root/MITMf/core/", line 21, in <module>
from mitmflib.watchdog.observers import Observer
ImportError: No module named mitmflib.watchdog.observers

I have tried to fix this with:
#pip install watchdog

But i still get the same output..Why?
Any help would be greatly appreciated.
Thanks in advace..

Join the Next Reality AR Community

Get the latest in AR — delivered straight to your inbox.

16 Responses

Sorry, you did follow the troubleshooting, kinda sleepy here.
Are you under VM?

hey Ciuffy,

Actually I got this info from your post(Defeating hsts). And was a quick 3 step install for me. So when things went heywire i went back to your troubleshoot. And tried all to no avail..Running on Usb Persistence..This worked fine for couple weeks.But i had to reinstall MITMf everytime i tried it out.Which was fine cause like i said a quick 3 step.But now thats all i get.

I fixed my answer before, anyway.

It seems like an import problem. Probably, they have revently trying to fix this screwing it up even more, but I am not sure: I can't access my computer now, can you locate this "mitmflib" in MITMf?

Am running on USB Persistence...And no i can't find in MITMf..

I think your right and they have ruined a great tool because this worked great a few weeks ago.Great in combination with Beef!..

Have same error on kali x64. On x32 machine everything works fine. I use downloaded mitmf due to issues with built-in. Probably kali v2 will fix it, or not.. independent vendor.

Don't exactly know yet what caused this, so i'll save the finger pointing.
Just install MITMf with apt-get instead:

apt-get install mitmf

The ways i used previously were:
1)git clone https:/ /github. com/byt3bl33d3r/MITMf.git
2)cd MITMf
4)pip install --upgrade -r requirements.txt

And that usually got things running.Not anymore.
If anyone figures out why that no longer works please add it to this post..Thanks

I will reinstall it and do some attemps to get it working.

Good News:

Fixed it. Going to fork the MITMf repo and share the working one asap.

Clone my fork instead and use my setup script:

git clone https: //
cd MITMf
chmod 777

This should take care of everything.

root@kali:~# git clone https: //
Cloning into '//'...
ssh: Could not resolve hostname https: Name or service not known
fatal: Could not read from remote repository.

Please make sure you have the correct access rightsand the repository exists.


After trying this on a clean Hard drive install, I was locked out of the system... What gives?

By the way when i first tried your solution I added new sources.list...And updated with these:
deb http: // sana main non-free contrib
deb http: // sana/updates main contrib non-free
deb-src http: // sana main non-free contrib
deb-src http: // sana/updates main contrib non-free
And followed your steps.Then I got locked out....

So i've since reinstalled,again, and updated with the older sources.list:
deb http: // kali main non-free contrib
deb-src http: // kali main non-free contrib

deb http: // kali/updates main contrib non-free
deb-src http: // kali/updates main contrib non-free

And retry your way once more.....

What does "locked out of the system" means?
And why did you change the sources file?


First, great work!! It now works perfect.....
Second here's what worked this time around.
I used the older sources.list to update before i attempted your suggestion:
deb http: // kali main non-free contrib
deb-src http: // kali main non-free contrib

deb http: // kali/updates main contrib non-free
deb-src http: // kali/updates main contrib non-free

But i don't think will work for the new upgrade.Not sure as my first attempt didn't go as planned.
I might add that step 4 is: ./
but i think anyone this far saw that. :-)
wont work for
Thanks 4 your attention...Am inspired to study harder.

Awesome, thanks for trying it out. You are running Kali 2 right?
Anyway, always a pleasure to help ;-)

Id try checking of all your repositories are updated then reinstalling mitmf. after that pip install requirements.txt
Also before you do all this check to see if mitmf works for you using the --help flag
mitmf --help
if so, start this process
(IT WILL TAKE A WHILE) do this when you have the time.

Share Your Thoughts

  • Hot
  • Active