Forum Thread: Kali 1.1 MITMf Not Working and a Question About Meterpreter

Kali 1.1 MITMf Not Working and a Question About Meterpreter

Hello guys, i just installed Kali 1.1 and i downloaded MITMf but it does not works.

Image via hizliresim.com

And i can not ping this computer. But i know it works and it is not using HTTPS web sites. What should i do?

Also i have a question about Meterpreter, please help me.

Really, how it works? We are typing our local IP address, and if victim is not on our network, how it works?

13 Responses

you cannot ping which computer? please be clear.. and also do post the screenshot after that in mitmf. so that i can help you if i know how to solve it.

I cannot ping 192.168.2.205 . I know it works, and have Internet connection. So i should be able to ping it. Am i right?

And there is no after. MITMf does nothing.

Note; i am using 192.168.2.205 too and surfing in Internet. I am not using HTTPS web sites, so MITMf can hook it but it does nothing.

Note2; sorry for bad English, i hope you can understand me.

From what it sounds like, mitmf isn't causing the issue. Does the victim machine have network connectivity? As for the meterpreter, when hacking LAN we use local IPs, this is because the connection doesn't have to leave our network. If we're hacking something on a remote network then we'll need to use our public IP, and configure our router for port forwarding.

-Defalt

Yes, victim has network connection. And i can not ping it, i know it works and it has network connection. So i should be able to ping it, am i right? What should i do?

Thanks for information. So if we want to hack someone in globe, we set LHOST to our public ip?

Can the victim machine ping the attacker?

Yes, it can.

For clarification's sake, could you provide some information about your network? Wireless or wired, switched, etc.?

Sorry for answering a question with more questions, but more information is needed to identify the issue.

I am using wired network. But i can ping other things, i can ping Google or i can ping my router. Just I can not ping 192.168.2.205, i have no idea why i can not ping it.

Note, I am sure on IP address.

Did you put your adapter into promiscuous mode before starting the attack?

Yes, i did. But i am not sure here is my netstat -i print;
eth0 1500 0 1174042 0 0 0 798186 0 0 0 BMPRU

note; i can not ping computers. i do not know why, i tried with another PC ( 192.168.2.198 ) and i was not able to ping it too.

try port forwarding, usually we don't port forward for the same network.
Hope it works OR trying changing the ip and give a static ip for victim

I tried them already.

Disable Firewall on victim computer

Share Your Thoughts

  • Hot
  • Active