Metasploit Error: Handler Failed to Bind

Whenever i try to set a multi handler this error occurs.
It Used to work for me but not working anymore
I thought that the port is still listening so i try to close it with Kill command but it didn't work for me so try fuser command but both didn't work for me please help what to do?

thanks in advance for helping

20 Responses

Try doing this on a different network and see how the results vary. If you still have the issue, I'm sure you'll find your answer on this forum in a matter of hours.

Hope this comment helps you out --
-Cameron Glass

It happened to me too.. but I ignored the error and it still worked

It's because you computer can't contact your external ip (maybe because it redirects to the gateway) but if you port forwarded it then it should work, Same thing happens to me

Are you sure that is the correct IP address for your kali box? The handler seems to not be able to bind to that address. Is something else running on that address? When it then binds to 0.0.0.0 do you still get your meterpreter session?

Thanks Guys for the help, i don't know what was the problem but it's working now.

i got the same problem but i cant fix it please help :'(

I had the same problem and it all was because my LapTop ip had changed. I had portforwarded it with 192.168.1.100 but it had changed to 192.168.1.101. Then I changed the ip for the portforwarding again, and it worked.

Try scaning your own IP addres using #nmap that will show you all you open port

  • Handler failed to bind to 192.168.0.1:1900:- -

Started reverse TCP handler on 0.0.0.0:1900
* Starting the payload handler...

I tried all the ports, 4444, 8080, 8888 and many more..
same error each time.
Help Please

it might just mean it's not vulnerable/exploitable. I get this error all the damn time.

  • Handler failed to bind to xxxxxx:8080(external ip adress) :( what should i do please

I think you should check if your port is open.

Try This,

use exploit/multi/handler
set payload to the 1 you want, make sure its, Reverse TCP
set LHOST ( Your External IP
set LPORT ( Port You Want To Use )
set ReverseListeningBindAddress ( Your Local Machine IP Address )
exploit -j -z

It still use's you external IP, but it binds to your local IP
Also make sure, that you are connected to you MAIN router/modem
And also make sure that the port you want to use is PortForwarded in some way

didnt work for me it giving me failed to bind any suggestions guys! thnx

As the others already said, check for the IP etc. If it all doesn't work, switch the network driver off and on again to kill all bindings... If it still doesn't work, reboot.

Try to use another port for multi/handler
I use 4444 or 8080

This happen if you don't use your kali machine private IP address ,Please use private IP address when setting LHOST in msfconsole .

The private IP can be seen in connection properties.
Here is the Screen shot.

Share Your Thoughts

  • Hot
  • Active