Forum Thread: Rescue-ssh.target Is a Disabled or a Static Unit

So last night I watch your video on how to install kali linux or re4son ons the Raspberry Pi 3 b+ and I got everything right until you putted in the command dpkg reconfigure openssh.service the I get the error rescue-ssh.target is a disabled or a static unit I looked on other forms for the command that wil help but none did, so please help.

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

15 Responses

Yes me too. I tried anything, but I have the same issue. If you have resolved the problem, please let me know! However, this website is the best one on the web!

rm /etc/ssh/sshhost*
dpkg-reconfigure openssh-server

Same and how do i follow threads ?

First do this:
rm /etc/ssh/sshhost*

Then run this again:
dpkg-reconfigure openssh-server

Had this problem earlier and this fixed it

I tried many different variations and also went to file system> etc> ssh but found four or five different files named ssh host

Understood what you meant but still the same problem persists although this time it creates SSH2 EDCA key and SSH2 ED25519 key but after that again the rescue line

this way still not solving the problem..
please someone help to solve this problem, i stuck on it too..

Oh I see now, what he meant is to remove all files starting with `ssh<underscore>host` inside `/etc/ssh/`

Hello. I had the same problem with the same message.....I formatted my sd card,and started over . I did just like the Null-byte YouTube video said. After I used to default login credentials . I right clicked the mouse and opened the terminal screen up. I typed apt-get update. It finishes getting the update.. I type apt-get upgrade it asked me to continue I typed y.. The Pi starts unpacking , after about 5 min the screen goes blank then the pointer , and curser flash Intermittently. I then restart the pi and it boots me into emergency mode.. That's where I am right about now... lol .. ....... I thought I could get around the static/ disabled line..

Hello, i tried everything i could find online including what was sugested here and in the reddit post but nothing seems to work does someone have a working solution?

root@kali:~ rm /etc/ssh/sshhost*
root@kali:~ dpkg-reconfigure openssh-server
root@kali:~ service ssh restart

Share Your Thoughts

  • Hot
  • Active