Forum Thread: Hacking Facebook,Twitter,Instagram Account Passwords with BruteForce

Sorry. It is Bruteforce again.

If you saw my tutorial on getting Instagram accounts passwords, there were lots of complains that the script was no working well. Well, that was not my script, so I decided to make one myself instead.

After a long time, I Present you, Faitagram.

I was disappointed, no one replied to this

Anyway enough talking, Lets get right into the tutorial.

Step 1: Getting Ready

By the way, Faitagram stands for Fa(cebook)(tw)it(ter)(inst)agram.
To clone the script, what you need to type in the terminal is :

git clone https://github.com/Juniorn1003/Faitagram.git/

To clone the Faitagram script.
After you cloned, type "ls" to see what is inside the folder.
After you typed that, you would see 5 things :

License, Readme, faitagram, setup.py and wlist.

License is just a MIT license, Readme has informations about the script on it, faitagram is the main source, setup.py is for the installing dependencies, and wlist is a wordlist.

You have that? Now lets chmod the files so we can access it.

chmod +x faitagram && chmod +x setup.py

We did that, to install all the requirements to run the script by typing :

python setup.py

It will install whole bunch of things.
You need to just wait.
After the installing is finished, there are commands for Facebook, Twitter, Instagram each.
The faitagram file contains a strong password list, so don't worry about the wordlists.
But if you still want to test it out, than use your own wordlist.
The format is :

python faitagram -s service -u username -w wordlist -d delay

In service, it is rather facebook,twitter or instagram.
username is for the username of the target.
wordlist is for the path to the worlist.
delay is optional, and it means the delay of seconds it will sleep during trying passwords.
the default of delay is 1 seconds.

There are 3 paths, pick one and follow me.

-FaceBook-

To start the bruteforcing on FaceBook, what you need to type is :

python faitagram -s facebook -u (email) -w (wordlist) -d (delay)

The (email) section, is for the email of the target.
The (wordlist) section is for the path to the wordlist.
And the (delay) is for the delays(seconds).
Delay is optional, just don't type the "-d" if you don't want to use it.
But, the others are a must.

If you don't have a wordlist, type "wlist" instead of the (wordlist).

Only in FaceBook, it will ask you to enter the name of the target.
It is just to prevent errors, and for Username Checking.

Here are some examples for the command :

python -s facebook -u BURGERKING -w wlist -d 3
python -s facebook -u MEMEBIGBOY -w /root/password.txt
python -s facebook -u NullByte -w /root/SadminDontBanMe.txt -d 2

-Twitter-

To start the bruteforcing on Twitter, what you need to type is :

python faitagram -s twitter -u (username) -w (wordlist) -d (delay)

The -s stands for service, -u for username, -w for path to the wordlist -d for delay(secs).
So what you need to do is put the username of the target in the (username) section,
path to the wordlist in (worslist) section. Those are a must, but -d is optional.
Just don't put the -d parameter if you don't want to use it.
Just like:

python faitagram -s twitter -u juniorn1003 -w wlist

Then the system will automatically set the delay to 1 second.

-Instagram-

To start the bruteforcing on Instagram, what you need to type is :

python faitagram -s instagram -u username -w wordlist -d delay

In the username, change it with the target's username, in the wordlist, change it with the path of the wordlist.

In delay, it is optional, you don't really need it, but change it with the interval you to be between bruting passwords.

If you don't want the delay, just don't type in the -d parameter.

How It Works

This script is completely made out of python.
It can never fail, because it uses selenium to do it.

selenium is a program to run an actual web and making the script doing the rest, but I decided to make it run it on a virtual display, using Xvfb and pyvirtualdisplay.

There might be errors, and that is the only thing that you should be awared while bruteforcing.
This script uses STEM for proxy.

I think that is all from me, Thank you for reading.

P.S : Sorry For Hoid, I made a new one Haha

Never Miss a Hacking or Security Guide

New Null Byte in your inbox, every week.

138 Responses

If You have any issues, do it here.
If you have Questions, comment.

Do i need kali linux for this to work?

Yes, since tor needs to be in here. I am also trying to make a version that works without kali linux.

Have you come up with anything that works without Linux or tor? What about Brutus any suggestions can it work through there?

hey it tells me no such file or directory....when i run chmod command

cd Desktop
cd Faitagram
chmod +x faitagram && chmod +x setup.py

Follow these steps

Traceback (most recent call last):
File "setup.py", line 28, in <module>
fp = open("/etc/tor/torrc")
IOError: Errno 2 No such file or directory: '/etc/tor/torrc'

sir how to fiix this error

What went wrong? Did everything you said, installed selenium and tor.

Hey
I'm using MacOS and I dont have kali so would this work if I made Tor my default browser?

Hello sir ,
Done everything as per instructions but getting: oserror=errno 2 no such file or directory
Program install error!
Any solutions please!!

when i run this "chmod +x faitagram && chmod +x setup.py"
it shows

chmod: cannot access'setup.py' no such file or directory

it worked for me when i chmod the two separately, for example doing

chmod +x Faitagram

then

chmod +x setup.py

if that doesnt work, try using cd ~/Faitagram to run the command

hope that helps

hi justin
when i use this :
python faitagram -s instagram -u username -w wlist -d delay
when i run it appear this false
(File "faitagram", line 263
python setup.py)
what the problem ???
hope u answer quickly

Sir your python script still do have errors. cant take a screen shot so texting errors below
Checking Username...

Traceback (most recent call last):
File "faitagram", line 159, in <module>
main()
File "faitagram", line 47, in main
Bruter(service, username, wordlist, delay).execute()
File "faitagram", line 66, in execute
if self.usercheck(self.username, self.service) == 1:
File "faitagram", line 77, in usercheck
driver = webdriver.Firefox()
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/webdriver.py", line 148, in _init_
self.service.start()
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/common/service.py", line 81, in start
os.path.basename(self.path), self.starterrormessage)
selenium.common.exceptions.WebDriverException: Message: 'geckodriver' executable needs to be in PATH.

And sir one more request , why dont u teach us how to make a python brute force script of our own or atleast tell what to learn in python for making a brute force script.

thanks,
Xceed

I am computer illiterate and I admit it. But I need someone's help. I know my gf's MAC address (on her phone) The email address she uses for login, at least 5 former passwords, and just about everything about her. Can someone help me get into her fb messeNger? I am 100% certain that she is cheating on me, but I don't have the smoking gun. I KNOW she is cheating, but every time I confront her she flips it and makes me feel like shit for even asking. If you have ever been wronged by a lying woman, please HELP me get the proof I need to put my mind at ease.

If you don't trust her, dump her.

Easy.

Kids has friends
adults has relationships
Ledgens are single.

Best words ever Said!

if you are in contact with her ... use metasploit and some social engineering to compromise her phone.. then facebook..insta..whatsapp or what ever you want

how does that work?

i'm in the exact same situation with my boyfriend it's so frustrating because he won't admit it and im dead sure he is cheating on me

Arrriiigth.

Steps i was through that was not included in the tutorial:
-Install TOR: sudo apt-get install tor

-Install Selenium (Had the same PATH problem as the guy Xceed): found random youtubevideo that got the right codes to use in description. (It worked)

After that i started testing Instagram.
After 3 attemtps:
ERROR : ERRNO 111 Connection refused.

Last script was jumping IPS after 3 attempts. Perhaps you could change the script to jump ip after 2 attempts?

Update

  • Tested twitter aswell. Got same error after 3 tries.
  • Anyway. The script find the right password (within the 3 times). Tried to change password on a test account i got to second password in the wlist. It did find the right password and script stopped.

ALz

By the way, this problem was solved in the Issues section in the repository.

Hi ALz,

Could you please tell me the link how to install Selenium, I cannot find valid one

Boss :)

Don't you think , Facebook, Instagram or twiiter will lock you out after some couple of password tries ... or it may ask for Human Verification.

Any Solution for this?

So it will not lock unless the proxy is fully functioning.

can you show us how to get the proxy working so that it doesnt error 111 out after 3 tries

Yes, working on that.
Please just wait about a week or so.

Justin,
Thank you so much for putting this together.

This is working fine. Few details may help here:

1) part of the problem coming from tor service. systemctl is starting only socket port and not starting control port. As a result when j % 3 = 0 codeblock is calling the setIP, it is not able to communicate with the port. I started tor using by just loading the tor browser. After starting tor browser, ensure it is listening to both 9150 and 9151 port. This can be confirmed via "netstat -ntlup' command in your terminal window

2) setIp function calling controller.authenticate api function. The functionality depends on the torrc setup. You can confirm tor configuration file location by "systemctl status tor.service" command in your terminal. The output should show trorrc location. If your torrc file using "CookieAuthentication 1", then change the script from controller.authenticate(password='tor_pasword') to #controller.authenticate()

Hello Vanguard, I Thank you for your suggestion.
2 days ago I already automated the torrc process, now I only need to do your suggestion! Thank you very much.

Justin,
i just saw you made some update. Thank you for new version. I wanted to just ask few questions

1) Can the flow control be improved? the main loop is from word list file. For each, word in word list, you are discovering the email element. However, that is constant, so why not grab email element outside of the loop. During loop, just send password, delay, go to next cycle.

2) same thing, inside the loop we are checking what service we are working on then, we deciding whether we got in or not. I know one if statement is not expensive but why continue to do the same thing. Can we not make them part of initialization step?

This is what I am suggesting, in your init state:

you already know the service you are working on, so come up with three variable there

1) usercheckinquire_url
2) auth_url
3) email element
4) assert statement for validation

Then you just pass those parameter during you later call; specially webBruteforce loop can benefit from that.

Tried it to brute-force my Facebook account , and it failed after 3 attempts .
Error 111

/etc/init.d/tor restart

you have to make sure tor is running.

Hello.I tried to bruteforce an account but after 20 tries is stops cause proxy's are not working .How I can fix it ?

Sorry for the late reply, apparently my real account was not working, null byte was VERY buggy in logging in. I am currently working on the proxy, the problem is that it is hard to change the IP during selenium is running, so I am figuring that out.

trying to get an old Instagram account that is not being used. After the 6th password, the script says it got the password which it didn't. When I restarted the script, it said it got the password right the very first try which it didn't. Am I doing something wrong or did the account get locked out?

No there is a problem with proxy .The boss is trying to fix it .I have the same problem .

What the hell , when i try to use the "sudo apt-get install tor" it says the command apt-get doesnt exist and when i try the "pip" commands it also doesnt work .

(Im on Mac btw)

Lol it took me a while to find out this is for Linux
Guess I'm going to make a Virtual Machine then

Hello there!! very nice tutorial! :D i have one question at -w <--- what is the path? i want to use your wordlist, which is strong as you said...

the name is "wlist", so just do -w wlist

So for those who are mentally retarded and do not understand any of that, can someone lend a helping hand in cracking a FB password?

I can not seem to install tor as when i try to do apt-get install tor it says it has no installation candidates but i have tor already setup and connected but it does not seem to know, so what can i do?

Did you write the script in kali with pico for example or did you write it on a Windows/Mac machine?
Just wondering

Both. I test it on kali, and I write it on windows since notepad is way faster and convenient than gedit or nano.

Any help with how to solve this error everytime I try to run this for instagram?

sh: 1: /etc/init.d/tor: not found
Traceback (most recent call last):
File "faitagram", line 267, in <module>
main()
File "faitagram", line 65, in main
with open('/etc/tor/torrc','r') as f:
IOError: Errno 2 No such file or directory: '/etc/tor/torrc'

Okay, got it to work but after 3 attempts I get this error,

Error : 0x01: General SOCKS server failure

Any ideas?

Hey Friends,
I am getting an error while working upon this method. Can you please help me out through this error.
IOError: Errno 2 No such file or directory: '/etc/tor/torrc'
I am attaching the error picture with this.
Hope you guys help me out.

Regards,
Aarzoo Alam

Looks like you don't have torrc, you should have tor and you should have it.

So have all the socks errors been fixed? Does the script work at the moment? I dont want to boot up into Kali and find out it'll fail after 3 attempts etc. Great work btw

Not yet, sorry. It's just hard to use proxy with selenium. But I promise I will fix this.

is there a way to automate the built in proxychains function in kali to switch proxys with a given time? if so why not just ditch the proxy within the script and instead just run it through proxychains.

you would only need to use the randomchain option just with a long list of usable proxys in the .conf file as its too slow to run the dynamicchain or strict_chain

Thanks for the advice! Will try this out.

ok Restarting tor (via systemctl): tor.service.
ok Successfully Scanned Password : 872860B76453A77D60CA2BB8C1A7042072093276A3D701AD684053EC4C
Traceback (most recent call last):
File "faitagram", line 267, in <module>
main()
File "faitagram", line 75, in main
Bruter(service, username, wordlist, delay).execute()
File "faitagram", line 101, in execute
if self.usercheck(self.username, self.service) == 1:
File "faitagram", line 118, in usercheck
driver = webdriver.Firefox()
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/webdriver.py", line 158, in _init_
keep_alive=True)
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/webdriver.py", line 154, in _init_
self.startsession(desiredcapabilities, browser_profile)
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/webdriver.py", line 243, in start_session
response = self.execute(Command.NEW_SESSION, parameters)
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/webdriver.py", line 312, in execute
self.errorhandler.checkresponse(response)
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/remote/errorhandler.py", line 237, in check_response
raise exception_class(message, screen, stacktrace)
selenium.common.exceptions.SessionNotCreatedException: Message: Unable to find a matching set of capabilities

Have kali Linux I'm getting stuck right in the beginning i type last and none of those folders show up it tells me cannot access Faitagram

Right from the start it asks me for a github username and password and the other tutorial tells me to download tor which i keep trying to do and I'm getting errors and it won't go through

When i do it out of wordlists i still don't get the right folders

Finally got past that went through everything got to the last step and this freaking TOR thing again...."no such file or directory" error it won't seem to install tor i tried everything

Hi, I am trying to do this but I am having alot of trouble. Could you possibly make a more indepth tutorial on how to do this? Example, what it is you need to download, how to set everything up, etc. Because currently to me, someone who does not know how to code it is quite confusing. Thanks!

Is there any kind of similar path without tor? Still can't get this downloaded I've tried everything

Selenium installs fine still just tor only reason i can't finish this bc of tor. Anyone have any ideas or scripts to follow?

Man you lose half of the trust with the tile. Wordlist is not bruteforce...

Finally got the song working to install tor and now half way through install my computer completely freezes here. Is this normal do i just leave it and wait it out? Or anyone know why whenever i try to install tor it freezes up my system and i have to reboot

Funny how all the skids think that running a script without errors would work. This is where google comes in handy. Just calmly Google all the errors.

P.S. I suggest you also mention which version of Selenium you're running and Python version.

I've googled everything for days. Finally got tor download to start working then get a failure at the end of it for not enough space. Now I'm trying to run a swap script and that's also failing can't get that working. Any suggestions how i can get tor on this thing

does this work on mac?

Can I pay someone to get into an Instagram? This is a lot of new language for me.

After python setup.py i get error cannot access geckodriver?

Having an issue with geckodriver right at the end of script. Selenium and tors installed but won't open Mozilla saying geckodriver not found.

After 3 weeks of tor/selenium issues i get it all to work, run the python Faitagram script andget message: connection refused

This is a problem lots of peoples have right now, I will try to fix this until march.

I changed the setup.py file to run a specific version of geckodriver and it worked. Everything installed fine went to run the python faitagram command and after about 10 seconds of looking for the password Mozilla pops up a blank screen and I get an error saying that selenium cant open the webdriver. Trying to update my firefox (currently have 52.6.0) with apt-get install firefox and get error E: Package has no installation candidate. apt-get update worked fine but still couldn't install firefox. apt-get upgrade told me I needed to update my kernel for some packages. Is this definitely my system or is it the script possibly? Asking before I start going crazy I've been running into errors with kali for 3 weeks trying to run this script finally got to the last command and I'm stuck again-very frustrating

I got error like this:
Error : ('http protocol error', 0, 'got a bad status line', None)

could you help me to fix it.

please help
i am newbie in hacking world
so please help me
thanks in advance

I did all the things you said but when the bruteforce started this message appears after a minute :
Error : 0x01: General SOCKS server failure
I am a new kali user please help me fix this

hi please help me i am facing this error now

Getting an error when I run the script that selenium can't access the webdriver. I already have Firefox ESR and when I try and apt-get install firefox I get errors. Is there anyway of changing the script to use firefox esr with selenium instead of regular firefox?

I have been messing with this script for a few hours now... I keep running into the same error {111} connection refused this is really annoying and it would really make my day if you could get this script working... also a recommendation

you should put a changelog in your original article so viewers know when it was updated and what has changed. good luck on this script mate.

Receiving error Selenium unable to find matching capabilities

Again, still receiving error selenium is unable to find matching capabilities. Need help....anyone?

hi pro

I am sure that your way us working but I am having a small problem I am new for hacking so if you can PLZ help me these are some screenshot of my problem

Step 1:

Step 2:

Same.. Please tell me how to solve it...TT

Has the SOCKS error been fixed yet ? great way, i haven't found any other ways online please fix the error soon

Error : 0x01: General SOCKS server failure

Someone must have come across this before. Is this something to do with my provider or did I do something wrong??

same problem here

ok Restarting tor (via systemctl): tor.service.
Traceback (most recent call last):
File "faitagram", line 254, in <module>
main()
File "faitagram", line 63, in main
Bruter(service, username, wordlist, delay).execute()
File "faitagram", line 89, in execute
if self.usercheck(self.username, self.service) == 1:
File "faitagram", line 106, in usercheck
driver = webdriver.Firefox()
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/webdriver.py", line 152, in _init_
self.service.start()
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/common/service.py", line 76, in start
stdin=PIPE)
File "/usr/lib/python2.7/subprocess.py", line 394, in _init_
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1047, in executechild
raise child_exception
OSError: Errno 8 Exec format error

How can I solve this issue?

Any luck in solving it? It seems that i had the same error as you

I got this error after i tried installed everything as told in the guide. I typed in the brute attack format and this is what i got. Anyone can help?

Hey Justin. Since I don't have the proper tools (Kali Linux, a decent pc, Tor), I was wondering if maybe you could run the script on a certain account for me. I would really appreciate it as I am the biggest noob with this stuff and I am 90% likely to break my PC trying this. Thanks. (P.S The username is: dakotaz)

can somone help im getting the 0x01 error General SOCKS server failure, would really appreciate it if someone helped :)

Same error here :(
Is it fixed anyone?

Someone got a fix to the proxy problem ?

Hi,

Thanks for this script! I'm having an error each time I try the script. Can you try to tell me what I'm doing wrong?

Thanks!

Regards,

Dash

guys/girl, anyone fixed the proxy issue

Anyone have any success? I'm still getting the 0x01: General SOCKS server failure

Still getting 0x01: General SOCKS server failure. Assuming everybody has given up?

hi , any way to pipe crunch to this ? i meant instant check of pass with out save
pls man i need to check all possibilties

so, no one is helped? i see the problem comes about 5months ago and yea, people keep asking those same error.

I cant install tor, every time i use sudo apt-get install tor or apt-get install tor the code wont run a gives me an error : couldn't find the package.

Any suggestions?

i'm using ethernet to access internet. Will it work?

ive installed it all correctly, but had to modify the setup.py script since the geckodriver website was not valid, so i changed the last lines of the setup.py script as follows (the line after the # are the original and the modified lines are underneath)

#os.system("wget github.com/mozilla/geckodriver/releases/download/v0.{}.{}/geckodriver-v.{}.{}-linux{}.tar.gz".format(first,second,first,second,OS_bit))

os.system("wget github.com/mozilla/geckodriver/releases/download/v0.19.0/geckodriver-v0.19.0-linux64.tar.gz")

#os.system("tar -xvzf geckodriver-v0.{}.{}-linux{}.tar.gz".format(first,second,OS_bit))

os.system("tar -xvzf geckodriver-v0.19.0-linux64.tar.gz")

#os.system("rm geckodriver-v0.{}.{}-linux{}.tar.gz".format(first,second,OS_bit))
os.system("rm geckodriver-v0.19.0-linux64.tar.gz")

and then i left the rest of the script the same since the geckodriver executable was fine

os.system("chmod +x geckodriver")
os.system("mv geckodriver /usr/local/bin/")

the install worked perfectly and i was able to get to this point in the README.md where it told me to run it as follows (im using wlist instead of an actual wordlist.txt file)

>python faitagram -s facebook -u MeMeBigBoy@gmail.com -w wlist -d 10
>Traceback (most recent call last):
File "faitagram", line 2, in <module>
import argparse, mechanize, os, sys, socks, socket
ImportError: No module named mechanize
>

idk what this error means???

i also dont have any executable named "facebook" , i also cannot hit the tab button in ubuntu to autocomplete the line, for instance to run python in terminal without typing it all the way out i can simply type

>pyth
and then hit tab and it completes it to
>python
however this does not work with faitagram so i tried two things.

one, i renamed faitagram to faitagram.py and ran it but still no go
two, i tried to open python first
>python
hit enter and was in the python console but it still didnt work

any ideas? sorry for the messy upload

I am using ubuntu NOT kalinux is that a problem

Type pip install mechanize
This solved the issue for me.

Fake!!!!! it's not working properly it's only encouter password which is top of the wordlist .......I Tried many times by changing 1st password in wlist and that the showing it....If you anyone have SOLUTION then Reply me plzzzz..

In my case, after first try it is showing Error : 0x01: General SOCKS server failure

will this work on parrot os ?

After first try fails, it shows the following:
Error : 0x01: General SOCKS server failure

Restarting tor (via systemctl): tor.service.
Traceback (most recent call last):
File "faitagram", line 254, in <module>
main()
File "faitagram", line 63, in main
Bruter(service, username, wordlist, delay).execute()
File "faitagram", line 89, in execute
if self.usercheck(self.username, self.service) == 1:
File "faitagram", line 106, in usercheck
driver = webdriver.Firefox()
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/firefox/webdriver.py", line 164, in _init_
self.service.start()
File "/usr/local/lib/python2.7/dist-packages/selenium/webdriver/common/service.py", line 76, in start
stdin=PIPE)
File "/usr/lib/python2.7/subprocess.py", line 394, in _init_
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1047, in executechild
raise child_exception
OSError: Errno 8 Exec format error

Sorry, I just trying to pull your git. But it asking for credential (username, and password).

It didn't work for me. I tried it on Facebook and Instagram but it fails

hey my dear
i have two question
pls answer to me
1.can run this script un ubuntu???
2.when i run python setup.py get me under error how can fix this???

File "setup.py", line 42
chmod +x faitagram && chmod +x setup.py
^
SyntaxError: invalid syntax

thanks

I am having the same problem

nano setup.py
remove this line at the bottom: chmod +x faitagram && chmod +x setup.py

There are a lot of errors in your code.... I even had to tweak the setup.py for it to work. faitagram file needs a lot of work too. Generally bad code

im getting this error;
/usr/bin/python: can't find '_main_' module in 'Faitagram'
anyone know the solution?

File "setup.py", line 42
chmod +x faitagram && chmod +x setup.py
^
SyntaxError: invalid syntax

root@kali:~/Faitagram# python setup.py
File "setup.py", line 42
chmod +x faitagram && chmod +x setup.py
^
SyntaxError: invalid syntax
How i can fix it

Here can anyone extract the password of a Facebook account for me. Can pay for it.
If you can then DM me at ?? 9582953474

does anyone have solutions for this?
Help Me Out,

Share Your Thoughts

  • Hot
  • Active