Forum Thread: How to Install .Run Files on Linux

How to Install .Run Files on Linux

I'm new to using linux and I wanted to install Metasploit.

I used the chmod command to make it an executable file and then tried using the sudo command but is returns an error saying that the command is not found.

Here is the error:
paul@freedom Download$ chmod +x metasploit-latest-linux-x64-installer.run
paul@freedom Download$ sudo metasploit-latest-linux-x64-installer.run
sudo: metasploit-latest-linux-x64-installer.run: command not found
paul@freedom Download$

Please help!
Thanks!

15 Responses

If you want to follow more tutorials from this site maybe it is better to install Backtrack linux. it has most of te tools aready installed :)

Thanks Herman!

I know it's better if i have Backtrack but i don't think i have enough time to install Backtrack and get started. I will though. But for my purpose right now I think just having Metasploit will do the trick.

Kevin

Kevin:

That error is either from a misspelling of the command or you are in wrong directory.

If you wrote the command exactly as you show it here, you have a colon : that is unnecessary and is probably causing the error.

Finally, I agree with Hermann, you really should install BackTrack. It has so many more tools.

OT2

hi,
why not kali linux? isn't it the latest version of backtrack -with another name obviously?

Mert:

Either is fine but the new Kali has a few bugs.

OTW

oh, ok.
thanks for the quick reply.

Oh no the line in which the colon comes after 'sudo' if the result i got after I entered the command right above that.

Can it something wrong with the sudo in my OS??

Kevin:

Its probably not a problem sudo, but if you login as root , you don't need to use sudo.

OTW

I'm sorry I'm lost. What should i use?
Please help!
Thanks!

Kevin:

I strongly recommend that you use BackTrack.

The sudo command simply gives us "root" privileges for one command. If you log in as root, you don't need to use sudo.

OTW

Kevin:

Try directly clicking on the file it will give you installer but if it doesn't open then goto terminal then to the directroy and then type

./metasploit-latest-linux-x64-installer.run [press Enter]

it will get you the installer then install it!

try using sudo -i then type password and press enter you will become superuser.

Thanks Criss! But I thought it would be a lot better if i just got BackTrack.
Thanks anyway!
Kevin

im trying the same thing... i have Ampps-3.4-x8664.run on the desktop
i open terminal and type
cd
cd Desktop which gets me here
root@kali:~/Desktop#

how do i run the program?
i try
root@kali:~/Desktop# file:///root/Desktop/Ampps-3.4-x8664.run
bash: file:///root/Desktop/Ampps-3.4-x86
64.run: No such file or directory
root@kali:~/Desktop# sudo file:///root/Desktop/Ampps-3.4-x8664.run
sudo: file:///root/Desktop/Ampps-3.4-x86
64.run: command not found
root@kali:~/Desktop# sudo /Ampps-3.4-x8664.run
sudo: /Ampps-3.4-x86
64.run: command not found
obviously none worked... help?
om running rolling whatever 2016.1

to install any .run file in kali linux ,
first navigate to the folder consisting that file then type the following commands:
chmod +x filename.run and press enter.
./filename.run and press enter , sometimes you need be superuser so just use sudo .....

Share Your Thoughts

  • Hot
  • Active