Forum Thread: Aireplay-Ng "No Such BSSID Available"

Hi. I followed this guide

Anyone knows what could be wrong? Tried google but none of their suggestions fit my situation. They suggested that it was operating on the wrong channel but it selects the right one. They also suggested that the wlan0 interface was still active and it is not. I have Atheros chipset. I even tried bumping one of my own devices, still without any luck.

8 Responses

Can you show us the output of airodump and aireplay? Preferably as screenshots.


I think you need to change the bssid you have enter in parameter after the -a option.Try to use the BSSID of the A.P no this one of the equipment you want to deauth.

In this case:
"aireplay-ng -1 0 -a A0:63:91:20:04:F2 -c (mac adrr of the client) wlan0"


aireplay-ng --deauth 1 -a AP-MACadr -c Client-MACadr wlan0mon worked. Thanks a lot :).

You entered the wrong BSSID.

Ye. I misunderstood. Thought it was the ClientMACadr after -a. Dummy me :)

I having the same problem but deauth nevet works on right channel
Where i should provide channel information?

You've provided the client MAC instead of BSSID.

Sometimes even with the right BSSID, you'll face the same issue. Try Providing your ESSID using -e option in that case. That might work.

Share Your Thoughts

  • Hot
  • Active