Forum Thread: Kali 2.0 Airodump-Ng wlan0mon Doesn't Work

Hi i have problem in Kali 2.0 with airodump-ng im using an external usb wifi adapter:

root@kali:~# airmon-ng
PHY Interface Driver Chipset

phy0 wlan0 rt2500usb D-Link Corp. AirPlus G DWL-G122(rev.B1) Ralink RT2571

root@kali:~# airmon-ng start wlan0
Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID Name
772 NetworkManager
905 wpasupplicant
943 dhclient
1106 avahi-daemon
1111 avahi-daemon

PHY Interface Driver Chipset

phy0 wlan0 rt2500usb D-Link Corp. AirPlus G DWL-G122(rev.B1) Ralink RT2571
(mac80211 monitor mode vif enabled for phy0wlan0 on phy0wlan0mon)
(mac80211 station mode vif disabled for phy0wlan0)

root@kali:~# airodump-ng wlan0mon
ioctl(SIOCSIWMODE) failed: Device or resource busy

ARP linktype is set to 1 (Ethernet) - expected ARPHRDIEEE80211,
ARPHRDIEEE80211FULL or ARPHRDIEEE80211PRISM instead. Make
sure RFMON is enabled: run 'airmon-ng start wlan0mon <#>'
Sysfs injection support was not found either.

9 Responses

The error message tells you, run "airmon-ng start wlan0mon".

I had the same problem with mine, but I managed to fix it like this

airmon-ng start wlan0

airmon-ng check kill

airodump-ng wlan0mon

if that doesn't work try to
airmon-ng stop wlan0 after airmon-ng check kill

then just type as you would normaly do
airmon-ng star wlan0

airodump-ng wlan0mon

I hope this will help :)

Random Info:"The avahi-daemon discovers network resources, allocates IP addresses without the DHCP server, makes the computer accessible by its local machine name by acting as a DNS server and facilitates sharing of files and printers. The Avahi daemon is a default daemon in Linux and uses system resources and reduces the network performance."

------------------------------------------------------------------------------------
D-Link DWL-G122 B1

Manuf/OEM/ODM Alpha Networks WUS-G05

FCC approval date: 03 August 2004
Country of manuf.: China
Interface: USB

USB 2.0
Connector: Male A
Form factor tags: dongle

ID: 2001:3c00 (1 addl. devices)
Windows: USB\VID2001&PID3C00

FCC ID: KA2DWLG122B1
WI1 chip1: Ralink RT2571

WI1 chip2: Ralink RT2526

Probable Linux driver
rt2500usb (in backports)
USB ID first seen in kernel v2.6.24 (2008-01-24)
(see also passys)

Windows driver
see MediaTek's website

Antenna connector: none

bg

OUI: 00:11:95 (12 E, 22 W, 2004), 00:13:46 (14 E, 20 W, 2005), 00:15:E9 (13 E, 15 W, 2005)

D-Link DWL-G122 rev A1 Intersil Intersil
D-Link DWL-G122 rev A2 Intersil Intersil
D-Link DWL-G122 rev B1 Ralink Ralink
D-Link DWL-G122 rev C1 Ralink Ralink
D-Link DWL-G122 rev D1 Marvell Marvell
D-Link DWL-G122 rev E1 Ralink
D-Link DWL-G122 rev F1 Realtek

----------------------------------------
This card will packet inject so it's something on that end. Maybe like Comment #1 and #2 suggest.

use
ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlan0 up

PID Name
772 NetworkManager
905 wpasupplicant
943 dhclient
1106 avahi-daemon
1111 avahi-daemon

kill some of These processes, especially avahi-daemon.

Do it like this:

airmon-ng start wlan0mon
see if it lists processes
kill one of them
airmon-ng start wlan0mon

repeat until no interrupting processes are listed.

For me, both the NetworkManager and the avahi-daemon made Monitor mode impossible.

first put it in monitor mode and then try again, should work

I've had that problem since kali 1.0.9 use:'iw phy phy0 interface add mon0 type monitor' to create monitor mode on 'mon0'.

Thnx , but after that i cant find any station associated to wifi target

After spending more than 1 week and buying two adopters of kali compatible chipset atheros and ralink..I was still facing the same problem but last night I found the solution..It would seem weird but seriously it works and it seems logical if you think from hardware point of view..and also you need to have kali compatible network cards... I you have a device that is compatible and still facing the problem then simply so to usb settings in VBox for your virtual machine and change it to 3.0 and everything would work like a charm, :)

Share Your Thoughts

  • Hot
  • Active