Forum Thread: Airdump-Ng Can't Find Any Network in Monitor Mode

I know quiet well linux and decide to start with kali linux few weeks ago. So i installed it on my usb key and boot in persistence mode with it. Everything worked as i was expecting, wifi connection... But i wanted to try aircrack-ng so i began with scaning networks but it doesn't seems to work :

root@kali:~# airmon-ng

PHY Interface Driver Chipset

phy0 wlan0 ath10k_pci Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

root@kali:~# airmon-ng start wlan0

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to run 'airmon-ng check kill'

PID Name
3264 NetworkManager
3276 wpa_supplicant
3628 dhclient

PHY Interface Driver Chipset

phy0 wlan0 ath10k_pci Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

(mac80211 monitor mode vif enabled for phy0wlan0 on phy0wlan0mon)
(mac80211 station mode vif disabled for phy0wlan0)

root@kali:~# airmon-ng check kill

Killing these processes:

PID Name
3264 NetworkManager
3276 wpa_supplicant

root@kali:~# airmon-ng

PHY Interface Driver Chipset

phy0 wlan0mon ath10k_pci Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

root@kali:~# airodump-ng wlan0mon

CH 4 Elapsed: 18 mins 2018-01-11 21:37


BSSID STATION PWR Rate Lost Frames Probe


As you can see airodump-ng didn't catch anything whereas monitor mode is activated.

I use my native wifi card so is it possible it is not compatible with aircrack ?
See what does return aireplay :

root@kali:~# aireplay-ng --test wlan0mon

21:42:18 Trying broadcast probe requests...
21:42:19 No Answer...
21:42:19 Found 0 APs

Do you know if i have to buy a wifi usb or is it something else ?
Thanks for you help in advance

Join the Next Reality AR Community

Get the latest in AR — delivered straight to your inbox.

11 Responses

This wifi dongle seems nice and not expensive. In addition i was looking for a wifi dongle compatible with my raspberry and it is. Thank you for your quick answer.

Yep works like a charm with Pi too! No biggie.

I just got the ALFA AWUS036NH and running into the same problem. I disabled the builtin laptop WiFi and have the Virtualbox on bridged under networking set all that stuff up.

Once in Kali I get through everything and airmon is searching but no results. This card is on their list too. However I noticed something really strange it almost seems it's using a loop back address and I think this might be the problem.

The laptop has no internet connected when I try all of this. I am wondering if Virtualbox is causing all the issues with the SDN.

hey. Did you perhaps find a fix for this? I seem to be having the same problem

I'm in the same boat Anybody ever solve this?

Hi there, i had the same issue with a Ralink RT5370 Wifi Dongle (this one: Ralink WiFi Dongle für Mag 250 254 255 260 270 275 RT5370 Chipsatz WiFi Dongle für viele Set-Top-Boxen)

I was able to use the device as Wifi-Managed mode as a normal connection and put it into monitor mode. But the test with aireplay-ng --test wlan0mon turned out the same error

Found 0 APs

I managed to fix it by following these steps:
apt update
apt install firmware-ralink
apt install iw

and run aireplay-ng --test wlan0mon again.
now it works nicely

But i am unsure if the next steps like besside-ng would work though :)

it was working fine first but after i reinstall kali,it cant find any network

I found this solution by my own, I don't know much logic behind this but YOU NEED TO CONNECT YOUR DEVICE TO DIFFERENT ROUTER/ MOBILE HOSTPOT,

sorry if want solution connecting to that same network.
I connected to Other WIFI network it works and it was giving empty output when I connected to one of my mobile hotspot.

Does this drawing style have a name?

Share Your Thoughts

  • Hot
  • Active