Forum Thread: I Can't Hack Anything with Metasploit

I tried to hack my android 7.0 with all exploits from metasploit but no one worked.Do you have some tips? How can I hack with a link?

Never Miss a Hacking or Security Guide

Get new Null Byte guides every week.

5 Responses

Do you have any kind of error ?
Do you have any session opening when you launch "MainActiviry" on your android device ?

Be sure that the port you're listening on is forwarded :)

when i try to use samsungknoxsmdm_url i get this error
: Target has required an unknown path: favicon.ico
Exploit requirment(s) not met : os_name

You need to learn a little about what it is you are trying to achieve. Not to be rude or anything but it sounds like you have no ideer of what you are doing

First of all you need to make sure your attacking machine can connect to your target. Do that by downloading a program called tcping and ping the exact port you want the remote shell to run on.

Next make an exsploit app for the target. I'm not gonna explain how to do that since that is a part of the learning and understanding what you are doing process.

After you have made the exsploit you have several options on how to get it to the target. The easiest way is to download it(from your attacker machine running "apache server") or transfer it directly.

Make sure you have msf listening for a reverse connection when activating/running the app....

What do you mean with download it or transfer it directly?

Share Your Thoughts

  • Hot
  • Active