Forum Thread: Is Reaver Dead?

Is Reaver Dead?

Is the Wi-Fi key cracker dead or still breathing?

Because in my experience which is a bit premature and is only based on testing on 3 laptops and 2 kali distros namely Kali 1 and Kali SANA, Reaver hasn't worked for me. It used to do its charm till the mid of last year i.e. 2015 but with the advent of new routers that come with improved technology and lock-out defenders, reaver remains at bay now. It gets interesting when you test it against the same old routers that you once used to employ it against and get the password within 4-5 hours of cracking but now surprisingly it doesn't work against them either. I have tested it against two such routers. It is giving results against one of them but only on the previous old Kali distro not on the Sana one. While no results at all against another router on both distros. I'm attaching a screencap as a piece of evidence to prove my point.

What exactly is happening? Why is reaver being cornered and why haven't they done anything to make it better or immune to the lock-out plague?

If you try reaver now, it is extremely arduous to get it associated with the AP in the first place. It takes around 5 minutes to associate with the targeted AP and once connected, it makes a few PIN attempts and then again displays the same 'Unable to Associate' message.

If you somehow get through that phase unhurt, there's a very high probability of you receiving the "Retrying previous PIN" message which seems to stay there no matter whatever code and command magic you cast.

If you have managed to bypass that as well, then comes the ultimate weapon called the lock-out technology against which reaver is clueless. So it stops the process and sits there like a defeated warrior with a message "AP rate limiting, cracking shalt be resumed after __ seconds depending upon the delay time you have set". I have tried setting the delay time to even 10 minutes only to receive the same message again.

Can someone shed some light on what's going on here and why haven't they done anything to save the one router PIN cracker there is?

Also, what other options do we have down our sleeves to hack a wifi network besides dictionary, wifiphisher and evil twin method?

Thankyou :')

19 Responses

Yup reaver used to do the job when I used kali 1.1 but when I switched to kali sana I get a loop, that too i'm using it on the same router -_-

I tried bully but it also didnt work properly on sana
The loop
! WARNING: Receive timeout occurred

Sending EAPOL START request
! WARNING: Receive timeout occurred

Sending EAPOL START request
! WARNING: Receive timeout occurred

Sending EAPOL START request
! WARNING: Receive timeout occurred

Sending EAPOL START request
! WARNING: Receive timeout occurred

Sending EAPOL START request
! WARNING: Receive timeout occurred

Sending EAPOL START request
Received identity request
Sending identity response
! WARNING: Receive timeout occurred

Hey guys , I think i have a solution for this.the problem occurs only with kali rolling and kali sana distributions.All you gotta do in this case is downgrade reaver pixiewps cowpatty and all other wireless attacks using apt-get purge command and download the old versions of these and install using dpkg command.DO NOT USE APT-GET since the repos are of sana and not to forget never upgrade your wireless attacks until kali shows up with some excuse. I am using a lenovo g-570 and this worked in my case.my chipset is of broadcom. And coming to Ap rate limiting I have already posted a method to overcome it. VIsit my post to see how to overcome AP rate limiting

Can you write the steps here for downgrading reaver? I'm using Kali Rolling.
Thanks.

after some research i found that the libpcap versions above 1.4.0-2 do not work properly with reaver

check your current version
> apt list | grep libpcap
or
>apt-cache showpkg libpcap-dev

download the old working version

> wget http://mirror.esc7.net/pub/Ubuntu/pool/main/libp/libpcap/libpcap0.8_1.4.0-2_i386.deb amd64 for x64

i tried to install multi pkg version for libcap with no success, you can try this rather than remove the current libcap version

if you can't like me, remove the current version !!! be aware to remove the pkg, you also may need to remove some dependencies such reaver itself

install the deb pkg

>dpkg -i libpcap0.81.4.0-2i386.deb (or amd64)

you may lock the libcap pkg version to prevent upgrades using Synaptic

reinstall reaver

>apt-get install reaver

and run!

>reaver -c 1 -i monX -b AA:BB:CC:DD:EE:FF -vv

Source: https://forum.aircrack-ng.org/index.php?topic=666.0

Will try it in a while. Can it be upgraded back with the apt-get update reaver command? And how sure are you about the fact that downgrading reaver will make it to work just like it used to in Kali 1?

the problem is NOT with reaver, but with libpcap version that is shared among other apps such nmap, wireshark ...

purge command will delete only reaver config files, not libpcap

In your previous comment, you said I may have to remove some dependencies. What are you exactly alluding to? Could you walk me through the whole process so that I could use reaver like I used to before all hell went loose? Thankyou !

when you run the command

> sudo apt-get remove libpcap-dev

apt prevent you to break your pkgs dependencies, you will be prompted to automatic delete some pkgs that DEPENDES on libpcap, otherwise they will not work without this lib

sudo apt-get remove libpcap0.8
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
aircrack-ng libblas3 libc-ares2 liblinear-tools liblinear1 libsmi2ldbl
libwireshark-data libwireshark3 libwiretap3 libwsutil3 python-scapy
python-sqlalchemy python-sqlalchemy-ext
Use 'apt-get autoremove' to remove them.

The following packages will be REMOVED:
libpcap0.8 pyrit reaver tshark wifite wireshark-common

0 upgraded, 0 newly installed, 6 to remove and 0 not upgraded.
After this operation, 2,494 kB disk space will be freed.
Do you want to continue? Y/n

you will need to remove reaver as well because it depends on libpcap to work.

some other libs used by libpcap and the pkgs to be removed, are no longer required

what you need is an old working version of libpcap.. sometimes you can handle multiple version of an lib or downgrade it, but unfortunately it is beyond my skills with linux

so after you delete the newest(not working) libpcap,

install the working version manually as explain in my last comment, and prevent it to be upgrade unsig synaptic(apt-get install synapitc)

once you run apt-get upgrade it will be auto upgraded

install reaver back again

>sudo apt-get install reaver

if you also may want to install bully(https://github.com/aanarchyy/bully), than you will need to install the dev lib found here : http://mirror.esc7.net/pub/Ubuntu/pool/main/libp/libpcap/libpcap0.8-dev_1.4.0-2_i386.deb (amd64 - x64)

Thanks for taking out your precious time to help me out. Much appreciated. Will give it a try this weekend.
Thanks a lot.

I'm glad to help you, i suggest you to install bully as well...
with the pixiewps feature you can crack some vulnerable routers to this atack in seconds!

Already tried that. It doesn't work for any of the routers in my country.

This page is another language. Translating it has messed up all the words and sentences don't make any sense.

just try google it like downgrading reaver or simply go back to kali sana instead of rolling

I had the same problem with reaver on Kali Sana. Any how I will give a try to your suggestion and see how it works. I hope this process is not irreversible (i.e. I can upgrade it back to the latest version)

Thanks for the help !

Hello guys, thanks for all of your answers, and now after some spent time on purge and install i finally resolve this.
I'm using Kali Rolling ,
libpcap0.81.4.02
reaver 1.4-2
and its works
its important because libpcap0.81.4.02 with reaver 1.5.2 doesn't work for me.
On Ubuntu 14 i have install
libpcap0.81.7.41 with reaver 1.4-2 and its work perfect

Thanks a lot guys for trying to solve this problem
sorry for bad english.

Cheers mates!

So pretty much the OS Kali Rolling is worthless. nothing works as it used to.. Reaver. Wifite nothing.. all junk because someone bugged it.. good thing I got my good old hard copies of backtrack. Fuck you big brother.

Share Your Thoughts

  • Hot
  • Active