Forum Thread: Probleme with Beef-Xss in Kali !

hey every one

i have a critical error wich Killed me this week with beef-xss when i try to run it( by typing in terminal beef-xss, its show the following error lines:

root@localhost:~# beef-xss -x
* Please wait as BeEF services are started.
* You might need to refresh your browser once it opens.
* Hook: <script src="http://<IP>:3000/hook.js"></script>
* Example: <script src=" "></script>
(process:26843): GLib-CRITICAL *: gslicesetconfig: assertion 'syspagesize == 0' failed
and the ui panel doens's show up on the browser
but when i go to /usr/share/beef-xss/ and i type ./beef -x it show the following error lines:
root@localhost:/usr/share/beef-xss# ./beef -x
10:35:14* Bind socket imapeudora1 listening on
10:35:14* Browser Exploitation Framework (BeEF)
10:35:14 | Twit: @beefproject
10:35:14 | Site:
10:35:14 | Blog:
10:35:14 | Wiki:
10:35:14* Project Creator: Wade Alcorn (@WadeAlcorn)
10:35:14* Resetting the database for BeEF.
10:35:22* BeEF is loading. Wait a few seconds...
10:36:09* 12 extensions enabled.
10:36:09* 241 modules enabled.
10:36:09* 2 network interfaces were detected.
10:36:09+ running on network interface:
10:36:09 | Hook URL:
10:36:09 |
10:36:09+ running on network interface:
10:36:09 | Hook URL:
10:36:09 | UI URL:
10:36:09* RESTful API key: 791bb557d38a1993c0c6ca437537fdd9fed65e75
10:36:09* DNS Server: (udp)
10:36:09 | Upstream Server: (udp)
10:36:09 |
Upstream Server: (tcp)
10:36:09* HTTP Proxy:
10:36:09* BeEF server started (press control+c to stop)
/usr/lib/ruby/vendorruby/eventmachine.rb:859:in `openudpsocket': no datagram socket (RuntimeError)
from /usr/lib/ruby/vendor
ruby/eventmachine.rb:859:in `opendatagramsocket'
from /usr/lib/ruby/vendorruby/rubydns/server.rb:122:in `block in run'
from /usr/lib/ruby/vendor
ruby/rubydns/server.rb:119:in `each'
from /usr/lib/ruby/vendorruby/rubydns/server.rb:119:in `run'
from /usr/share/beef-xss/extensions/dns/dns.rb:127:in `block (3 levels) in run'
from /usr/lib/ruby/vendor
ruby/eventmachine.rb:959:in `call'
from /usr/lib/ruby/vendorruby/eventmachine.rb:959:in `block in rundeferredcallbacks'
from /usr/lib/ruby/vendor
ruby/eventmachine.rb:956:in `times'
from /usr/lib/ruby/vendorruby/eventmachine.rb:956:in `rundeferredcallbacks'
from /usr/lib/ruby/vendor
ruby/eventmachine.rb:187:in `runmachine'
from /usr/lib/ruby/vendor
ruby/eventmachine.rb:187:in `run'
from /usr/lib/ruby/vendorruby/thin/backends/base.rb:61:in `start'
from /usr/lib/ruby/vendor
ruby/thin/server.rb:159:in `start'
from /usr/share/beef-xss/core/main/server.rb:127:in `start'
from ./beef:145:in `<main>'
so i tryed to reisntall the packtage ruby-dev but no changes
i'm using Kali 2.0
Any advices Please??

Join the Next Reality AR Community

Get the latest in AR — delivered straight to your inbox.

5 Responses

Had the same problem after starting.
Just start beef with the command (or just click on the icon) and let the console opened.

Then move to your browser and type in your local IP (not localhost) with the port "3000" and "/ui/panel" OR "/ui/authentication".


Give it a try, should work now ;)

i correct the bug just by restoring my old kali 3.14 its seem's that the probleme was in the new kali edition !

Maybe it is to late to answer to the original author but in case someone else needs it.

Try disabling the DNS extension. You can disable it in config.yaml by setting beef.extension.dns.enable: false (near the end of the file).

Answer found at the official GitHub BeEF page.

hi every one
i need help
my beef-xss tools
not opening the ui panel not apearing
ruby 2.2 issue
my kali linux version 3.14
plz help me

Share Your Thoughts

  • Hot
  • Active