Forum Thread: BeEF Integration with Metasploit

BeEF Integration with Metasploit

hello , i tried all the tutorials to integrate metasploit with my BeEF so i can make payloads and use the metasploit payloads and so on but it always gives me error

and also recently when i try to start beef from this commands :

cd /usr/share/beef-xss
./beef

it gives error about metasploit loading error

and in the end it gives error that BeEF is exiting because there is an app using the same port or it failed to bind with IP , but when i open the application it self from the applications list , it work no problem but no metasploit modules , and im getting really confused .

2 Responses

This video is for you

i configured as the video did , and metasploit loaded , thanks alot but there is a bigger problem now , when i load Beef from command :

./beef in the beef directiory , it says in the end that its exiting because there is other application is listening on the same port or im trying to bind it to a invaild ip , i tried everything and all tutorials on github from beef project , i reinstalled the program , edited config.yaml in all possible ways and i even reinstalled kali linux 2 . and its still all the same ...

i tried to check the port and see what is using it , and i figured its iceweasel using the same port , how to fix this ?

now when i try to use the BeEF but launching it from the application and editing the url with my public ip , all the commands isnt effective now , dosent appear to victim at all ... please help . i reinstalled beef and reinstalled kali linux and nothing helped at all .

Share Your Thoughts

  • Hot
  • Active