Forum Thread: Running Webserver on WAN

Hi ,

I have Been running Kali linux a while.and the problem i face is that i cant host my web server on WAN (for tools like beef,metasploit and setoolkit) .They are working fine in LAN but i dont how to set them on WAN.Please Help me to Solve this issue of mine

11 Responses

The best way to learn something is to understand how it works. Try reading some network security basics and later on advanced stuff and these kind of things will become easy and everyday tasks for you. Hacking will also be a lot simplified. You learn better if you find it logical.

That was in case you didn't do port forwarding. And I suppose you didn't. My apologies if you did. When a PC outside your network goes to your site, it sends a http request. Now your router or firewall recieves the request and doesn't know where to forward it to so it just drops the packet. If you forward port 80 (default for http) to your LAN IP of your web server it will know to forward every web request to that IP. Port 80 is default for apache, however, forwarding port 80 might be risky in some cases and in others, your ISP might block it. So i suggest going to /etc/apache2/ports.conf and changing the port to let's say 8080. Change it aswell in /etc/apache2/sites-available/default-000.conf. This way you will have to connect using your Ext. IP and port i.e. 12.345.678.90:8080. You can aswell use sites such as No IP to have a dns i.e. mywebserver.no-ip.com:8080. And that adress will forward anyone to your actual ext IP. Good Luck. -Ne-py

excellent explanation!

-Phoenix750

A little note on this port forwarding solution:

It doesn't matter on which port you are running the server on your computer. You can keep it running on default port 80, even if your ISP is blocking port 80. The one thing that matter, is that in your router you point another unblocked port (let's say 8080) and forward WAN port 8080 to LAN address 192.168.x.x (your pc) on port 80.

Also, make sure Apache or any other server is actually listening on the right interface, and not only loopback connections (those coming from 127.0.0.1 only)

i have already forwarded my port to 192.168.1.6:80 but what about my external ip ?

watch this https://youtu.be/bucsWEEuj6Y

i cant we my self on conyouseeme.org but i have forwarded my ports

If you have done the port forwarding as stated, then you're good. The reason why canyouseeme.org doesn't tell you that your port is open is because you don't have a service listening on that port. Turn on your apache server on the port you chose and forwarded, and then check that same port on the port checker site. Only then it will appear open.

my apache starts on boot and the apache default port is 80 rights i have forwarded port 80

as i said in my tutorial dont freak out if it dosent show! try another port like 5545 and listen on it then try if it didnt answer then try to see if you put right local ip or right visual there might be some thing wrong tho. ( it might happen if your router firewall blocks it as you see in my router i turned them off) in some routers it happen.

i am using natis

i opet forward to 8080. i configure apache ports to 8080 ,i configure site avalavle at 8080 i restart the apache but cant open the port at my ip :/

Share Your Thoughts

  • Hot
  • Active