Forum Thread: Trouble Using Wi-Fi in Kali Linux

Trouble Using Wi-Fi in Kali Linux

I am trying to get actual wireless capabilities inside Kali Linux inside VMware Workstation 12.01, not having my network being bridged to the host connection.

I disconnected my Netgear BCMUSB 802.11 wireless adapter from my host machine (Windows 10) and connected it to my VMware machine (Kali), but it seems like the guest machine isn't recognizing the adapter because when I open the network settings inside the guest, a wireless connection does not appaer.

When I change the view from full screen and on the main VMware toolbar go to VM - Removable Devices I see three things that interest me. Of course I see my Netgear Wireless Adapter, which is checked (connected to guest machine), Network Adapter, which I know is the exact adapter settings that your VM will use and is also checked, and the last thing I see is Wireless Receiver. Now this is not checked and seems to be connected to my host machine (since it is the same section as my Netgear Adapter). When I click on the Wireless Receiver to bring up another menu there are 3 choices, but the only relevant one is to connect it to the guest machine and disconnect from the host machine. So I select this option and it gives me a warning; "This VM is trying to claim 'Wireless Receiver'. If you continue, the device will no longer be usable in the host."

Now I don't know if I will permanently not have access to this "Wireless Receiver" or not. The reason I use quotes around "Wireless Reciver" is because when I disconnect my Netgear adapter completely from my computer, the Wireless Receiver device remains. And I know for a fact that I do not have a wireless NIC(Netework Interface Card) installed in my computer. Also I don't even know for sure if allowing this Wireless Adapter will allow wireless capabilities within my guest machine. It just caught my eye because I have been trying to figure this out for a while, and I've never seen it before.

Any input is helpful, I just want to make a very educated decision to avoid ruining my host's ability to connect to the Internet.

Be the First to Respond

Share Your Thoughts

  • Hot
  • Active