Forum Thread: Kali Linux WiFi Problem?

I'm using Alfa awus036nh. The problem is that my Wi-Fi card gets detected in the terminal but doesn't show available wireless networks. Also using airodump command returns me with nothing.

Does someone know how to remedy this?

Join the Next Reality AR Community

Get the latest in AR — delivered straight to your inbox.

41 Responses

What Network Connection Type you're using for the Virtual Machine ?

Yes, go to devices at the top menu of Oracle Virtual Box and click on devices. There you will see your Wifi adapter. Attach it there to your virtual machine.

Its already connected as can be seen in the snapshot.

Mate, I really need it to work. I've put so much of the pentesting work on delay because the first step (for me) i.e. WiFi network isn't working :( I used to have VMWARE PLAYER and it worked like a charm but then I updated to windows 10 and vmware player has compatibility issues with win10. So I have no other option then to use virtual box. I detest Live Boot and Dual boot options ! Please pour in some hard work into this and help me rectify it.

Thankyou for your response :)

I don't understand the problem then. From your screenshots, your WiFi adapter is connected.

What's the problem?

In the terminal when I write the command 'airmon-ng' and hit enter, it shows the adapter name (which means the adapter is connected to the VM) but in the WIRELESS NETWORK options, no wifi networks show up!

Also, as you know that airodump command is used to get a list of all wifi networks available, channel, bssid, ping etc - But when I give that command, no wifi networks show up there either.

In other words, the adapter is connected as per the screenshot but it doesn't show up available networks.

Did you run airmon-ng wlan0 start

if doesn't work try to download compact wireless.

Compact wireless drivers are installed in case the wireless interface (wlan) doesn't show up. But in my case, it shows up flawlessly. Kali does detect the wlan0 interface (Ra link) which is my alfa card. But it doesn't show up the available wifi networks which is what I'm looking for. Anyways, I have given a try to compact wireless and they haven't fixed the issue! :/

Mate, can you tell me is there a way to run VMWARE PLAYER on windows 10? Because everything was fine with vmware player until I installed windows 10 and now vmware player gives an error upon installation "This installed package is not supported by this processor type"

I'm running a 32-bit operating system while Vmware is only available for 64-bit OS. Is this error due to this fact?

It must show the 'AVAILABLE WIFI NETWORKS' under the Wireless Networks but its showing 'disconnected' instead.

Are you trying to use the WiFi card to attack Wifi or just connect to a network?

At this point I'm only trying to connect to a wifi network. But wifi networks aren't showing up in the WIRELESS NETWORK option.

It's been a long time since I've run Kali in a Virtual enviroment, or with an external USB. Is the Virtualbox install connected to the network via bridging on the host system?

Dude maybe urz in airplane mode dude.. just switch off ur airplane mode..and switch on ur wifi adapter according to ur laptop model.. fr example mine acer.

1.after switch off airplane mode in kali linux

  1. I press FN+F3 (bcz mine is acer) to switch in wifi adapter

To know how to switch off airplane mode in kali linux try to make some research in google..
Sory i forgot the link...
try and see.. bro
If not wrkng sorry.

,open your network manager, and click in preferences, and fill the field wireless interface with your wlan in your case is wlan0, then restart your connection

to restart your network run the command:
service networking restart
let me know if you stuck somewhere..


try to install wicd network manager

sudo apt-get install -d --reinstall network-manager network-manager-gnome
sudo apt-get install wicd-gtk
sudo apt-get remove network-manager-gnome network-manager
then reboot it

All right mate. Will get back to you once I'm done installing it.

Tried the very first command and it returned me with an error;
"Re-installation of network-manager is not possible, it cannot be downloaded"
"Re-installation of network-manager-gnome is not possible, it cannot be downloaded"

You are having so many problems. Why not try Virtual Box or VMWare Workstation?

What do you mean?
I'm already using Virtual box.
And Vmware Workstation can't be installed on 32-bit OS.


i was also see u in post with this problem in the Group of (facebook) kali linux .

I want ur help again here. So be focus what i,m trying to say.. In this image i see that u attached ur adapter with NAT interface....??

Remove And Change it....! to ( bridge interface ) and (then see the reply by me....? and follow those steps)

facebook group #kali linux.

#ar rehman.. ;)

I have already tried it with 'Bridge network' and it hasn't helped me either.

Dear hamza i was recomonded you that if you saw this post So you will see the post of KALI IINUX group which wrote by me And i also messege you in facebook first see it...

And one thing that you are so LAZY mAn...

K im having the same problem after playing that stupid airmon-ng rubbish, yes following stupid youtube tutorial. My wifi is now unavailable because of some executed cmds to start wifi into monitor mode. I didnt find aolution yet but at least i know what i need to search.

After setting up your adapter in VirtualBox, disconnect it from the PC.
Start the Kali VM.
Reconnect the adapter after kali is fully loaded and you should be able to see all the networks
Hope this helps :)

before u connect the wireless adapter to your kali linux ..i think u were connected to the internet through the eth0 if u want to change the interface and stop being connected to the internet useing the eth0( wired connection ) to the wlan0 interface (wifi conection ) type these commands

ifconfig eth0 down

once u type this the internet conection will go down ten u type ifconfig to see the avilable interfaces then u will see the wlan0 interface

type ifconfig wlan0 up
i think it will work probably

I'm pretty sure I read somewhere that you can't do wifi attacks from a virtual machine. It has to be from your OS. I'm pretty sure about this because last year I wanted to do some wifi hacking and had to take Kali off of VM and install Kali as my OS

Dear Hamza, have you solved the problem? If yes please help because I'm facing the same problem.

I am also having the same issue.using a ralink 3070L

i am using kali 2019.4 and while using the airodump-ng wlan0mon it show all empty BSSID list i dont know why i am using inbuilt wireless wifi adapter Qualcomm Athenos QC 9377 it show wifi on top of the notification screen and show some wifi but when i use command airmon ng it gives me empty BSSID list. i updated my adapter using sudo-apt update and sudo -apt get upgrade it upgraded all the pending one stilll no use i search on youtube but didnt find anything usefull.

But then i remember when i was dual booting kali while installing it gives me an error of ath10k pre cal pci 000 03 00.0 bin i downloaded all the files from github but still no use..HELP..!!!!!!

Same here, sometimes work sometimes not. The only time i got it to work was restarting like 5 times the network-manager.

Go On Virtualbox And Click On Device After That Click On Usb Setting And Change USB 2.0 to 3.0. that does not matter your wireless card is 2.0 or 3.0 just change 2.0 to 3.0- and then you can see the available network.

Share Your Thoughts

  • Hot
  • Active